ESP8266

Hey, I'm a complete noob and I am trying to connect my ESP8622 to my computer to program it. However, I cannot even get passed the first step. I can't get the ready message to pop up. I tried Arduino IDE, I've tried Putty, and even flashing it. Nothing will work.
Currently I have the 5v of the Arduino connected through a 1K ohm and a then a 2k Ohm resistor to the VCC, the CH_PD and the reset pins on the ESP.
The GPIO pin 0 is grounded and the ground is as well.
The TX of the Arduino is connected to the RX of the ESP and the RX the Arduino is connected to the TX of the ESP through a 1k ohm and then a 2k ohm resistor.
When running the Arduino IDE and you run the serial port, then type AT, nothing shows up in the box. When using the method print to serial it prints AT but nothing is returned. When using a flashing program it either says failed or cannot connect to device.
Right now there is a blue light and a red light on at all times.

PLEASE HELP ME.

Thank you in advance!

Hello.

Currently I have the 5v of the Arduino connected through a 1K ohm and a then a 2k Ohm resistor to the VCC

Why? Did you think that would be a good way to power the esp? It isn’t. You need a 3.3V regulator that can supply at least 300mA.

I use these ams1117 regulator modules:
$_1-1.jpg

You can’t use the 3.3V output from the Arduino. It can’t supply anywhere near enough current.

Paul

I thought I saw that online somewhere that I can use the 5v of the arduino to power the ESP, using resistors.

What would be the difference between that and a resistor?

Also that would go in between the arduino and the ESP?

I also tried the raspberry pis ports, and no luck there. Does that make a difference???

Would something like this work?

https://www.amazon.com/Blue3D-Ft232rl-Serial-Adapter-Arduino/dp/B012YUANZK/ref=sr_1_7?ie=UTF8&qid=1469988444&sr=8-7&keywords=usb+to+serial+converter+ftdi

or even this?

https://www.amazon.com/Qunqi-CP2102-Module-Download-Converter/dp/B014PBYER4/ref=sr_1_9?ie=UTF8&qid=1469988931&sr=8-9&keywords=Usb+to+Ttl+Serial

Thanks.

Esp tx to arduino tx and esp rx to arduino rx. Thats if you want direct access to the esp.
Load a bare minimum sketch on arduino.

I tried that, it didnt work.

Did you see this...

Yes, I read that many many times :frowning:

You must use 3.3v to supply the ESP8266. You can only use resistors to drop voltage when the current is constant (and a voltage divider only works to generate reference voltages - it can't supply any current). Current from ESP8266 varies from near zero to a third of an amp. You must use a voltage regulator.

Luckily, the 1k resistor wouldn't let enough current pass to damage the ESP8266, so you may not have destroyed your ESP8266.

Neither of the serial adapters you linked to will work without a regulator - one is 5v only, and the other one is an FTDI-based one, and while it can supply 3.3v, they can't supply nearly enough current for an ESP8266.

I breifly got it to work

I connected them as follows:

UNO --- ESP8266
RX ----- RX
TX ----- TX
GND --- GND
3.3V --- VCC
3.3V --- CH_PD

just like the link up-top said. Not sure why it worked this time.
But I was able to code to it and even put it on my wifi network.

Then I unpluged one of ground and plugged it back in. And nothing.

Not even the red LED.

However. when I plug it directly into the 5v both the blue and the red leds work. but no feedback.

magic smoke ?

if you let the magic smoke out, you lost the magic and need to get a new one,

I am not sure, but even if it did, it shouldn't be working on 5v