ESPExceptionDecoder en Arduino IDE 1.8.10

Llevo varios días intentando instalar la herramienta para descodificar los errores del ESP8266, siguiendo detenidamente las instrucciones de la pagina de github del proyecto pero no hay manera...

Los pasos que estoy siguiendo:

  1. Descargar el proyecto en un archivo comprimido
  2. En la carpeta con los proyectos de Arduino (en mi caso uso MAC es ~/Documents/Arduino) creo la carpeta tools
  3. Dentro de la carpeta tools creo otra carpeta que nombro EspExceptionDecoder y descomprimo el proyecto
  4. Inicio Arduino..

En teoría siguiendo esos pasos me debería de aparecer la herramienta en la pestaña de herramientas, pero no aparece nada. No se si será la version de la IDE de Arduino o es que estoy haciendo algo mal...

Yo lo tengo instalado en ubuntu y lo hice como has indicado, no tuve problemas.
El fichero es un .jar (esta hecho en Java) ¿Puede ser que no tengas java instalado en el MAC?

saludos.

Pues acabo de revisarlo y no lo tengo instalado... voy a probar a ver si es eso. ¿Qué versión de Java usas? Muchas gracias!

Ya he conseguido instalarlo. Al parecer, el archivo comprimido de github no contenía el fichero .jar, y siguiendo las instrucciones no se generaba. He encontrado en mi disco duro el fichero ESPExceptionDecoder.jar (no se de dónde habra salido) y al ponerlo en la carpeta de Documents/Arduino/tools/ESPExceptionDecoder/tool ha funcionado.

Ahora me pregunto por qué no se me genera el fichero .jar