Esplora Driver problem? Windows 7- COM vs. HID mode?

I've been working with various Arduinos for the last couple of years. Never had a COM problem before. But today, I gave my son an Esplora - brand new!

I've been through this setup several times, trying to troubleshoot it, so I have re-installed Arduino IDE 1.0.5 and 1.0.5-r2 several times. It's the same on both versions. To try to be consistent, I removed the program, deleted the driver in the Device Manager, rebooted the computer, re-installed Arduino IDE 1.0.5-r2, and then plugged in the Esplora. The board was recognized and driver installation began normally. First sign of trouble, the Driver installation has a red "X" - on one of two drivers???

I looked up the installation instructions on the Esplora "Getting Started" page ( , and as instructed I tried to add driver:

However, it reports that the driver is unable to install (note, I DID try this with the previous Driver Install window closed as well, no difference):

The Bootloader seems to have installed, so I decided to try to upload. It can't upload, but it gives me the helpful "try the reset button after you hit upload" message:

So I did that, and EsploraBlink works after I hit reset:

My son want to try EsploraKart, so I figured we need serial communication back from the Esplora. But the COM port does not work for Serial Monitor. Here's how I determined that: Since I had uploaded EsploraBlink and it worked, I then uploaded EsploraAccelerometer, which should give me data on the Serial Monitor. But as you can see below, it does not; no matter what sketch I run, I get the same "COM7 not found" message:

So: I can load sketches on to the Esplora by hitting the reset button after starting the upload (compile) process. But I can't get anything out of the Esplora on the Serial Monitor, and Windows says the device was not installed, The Esplora Kart page says that the Esplora should work as a normal keyboard, so I opened up notepad to see if I could get any output from it. I get nothing.

All of the above is on a fairly new PC (Asus P8Z77v Pro with a 3770 processor, etc) running Windows 7 with all of the current updates.

When I plug the Esplora into my Mac laptop, it works fine. OSX (Mountain Lion) recognizes the Esplora as a keyboard (even before we loaded any program onto it) and we were able to get keyboard outputs from it.

I searched fora online today before posting here. I was able to troubleshoot this far after someone posted a suggestion to look into the "COM & LPT" on the Device Manager. There is none! But I found out that if you unplug the Esplora, wait a moment, and plug it back in, "COM & LPT" shows up for a moment before it reverts back to "Other Devices>Arduino Esplora". If you're quick, you can double-click on the "COM & LPT" icon and have it open up the properties for the port. It's Port 7, which matches the Esplora Bootloader seen in the first screenshot above. It's possible to change the COM port there, but when the Esplora is the only Arduino plugged in and Arduino IDE is run, the Tools>Serial Port menu is ghosted out. This is different from any other Arduino board I have; for the rest of them, the serial port is automatically selected, and the Tools>Serial Port menu only allows the selection of the COM port to which the Arduino is connected (it's the only one in the menu). But with the Esplora, the Tools>Serial Port menu greyed out.

It seems really odd that the "Beginner" programs, like EsploraAccelerometer are not able to work. I read about the problem when the Esplora has been put into what I interpret to be HID mode, but that should be resolved by uploading a different sketch by pressing the reset button. And I was able to do that and upload EsploraBlink and EsploraTone several times.

Any help would be truly appreciated. :)

As it turns out, the behavior is almost the same on the Mac. Which is to say: 1. I can upload sketches, but only after hitting the reset button on the Esplora after hitting the upload button. This is the same as the PC. 2. I can't get feedback in the Serial Monitor from the Esplora, as in when running the EsploraAccelerometer sketch. This is the same as on the PC. 3. The difference is: on the Mac, the Esplora works as a keyboard/mouse (when running the EsploraKart program, for example). On the PC, I get no feedback from the Esplora.

This leads me to believe: 1. The Esplora HID driver on Windows is not working. The Esplora is trying to work as a keyboard, sending out serial-over-USB, but the Windows driver is not accepting the information. Or... 2. There's something going on where the Esplora has been identified by both operating systems as an HID, which is why the data can't be read by the Serial Monitor in the Arduino IDE. Or... 3. Maybe the Esplora is identifying itself as an HID, causing the computers to treat data from the Esplora differently?

I don't know if any of the above is true. Please let me know your thoughts.

thanks tzf

Esplora support is really bad. For the longest time I was the only one trying to answer things. Now I'm working with Adafruit Trinket. My poor Esplora sits in a bin.

Thanks TheKitty, even though you bear bad news! I wish I had known that before I bought the Esplora. I can't get any output from it except in HID mode. I guess I can buy a TFT display for it and do all my troubleshooting by putting the outputs on the display! :roll_eyes: thanks tzf