Esplora not showing up in Device Manager

I just bought an Esplora and have had no success getting it to connect with my PCs.

I have 3 different computers that I've tried this on. Two of them are running Windows 7, 32-bit and then I have another system running Windows 8.1, 64-bit.

When I connect to any of these computers nothing shows up in the Device Manager that says "Arduino" or "Esplora". I've also installed IDE 1.0.5-r2, selected the Esplora in the board menu and one one of my Windows 7 systems it gives me only one option of selecting "COM3" in the port menu. I don't know why it's even giving me THAT option since my Esplora is not showing up at all in the device manager. On the other two systems the serial port menu is just disabled.

I would also like to note that my Esplora came with a mini-USB cable but the receptacle on the board is for a micro-USB. Fortunately, I have a lot of standard micro-USB cables laying around but is this supposed to be using some special kind of cable?

This is my first Aduino and I am out of ideas here. Please help. Thanks!

OK, not sure now whether to remove this post or leave it up in case others find that they have the same problem as me..

Just to rule out the possibility of whether my board was faulty I went into the store where I bought it and did an exchange. Sure enough, the new box came with the correct USB cable and when I got it home and tried it out, it worked on the very first computer that I plugged it into.

So now I can say for sure that I just had a faulty board to start out with. Problem solved! No further help needed at this time.

The fact that the first one came with the wrong cable is probably an indication that it was something that had been previously purchased and returned to RS. Who knows whether it was the customer or RS that put the wrong cable in there, but at least we know why they returned it! ]:slight_smile: