Ethernet.begin

hello everyone..
i have this code

#include "Ethernet.h";
#include "SPI.h";
#include "sha1.h";
byte ip[] = {192,168,1,177};
byte mac[] = { 0x56, 0x34, 0x41, 0x30, 0x30, 0x31};
EthernetClient client;
int led = 13;
int bottom = 7;
int val;
char server[] = "192.168.1.5";



void setup()
{
 
  Serial.begin(9600);
   
 // Ethernet.begin(mac, ip);
  
  pinMode(led,OUTPUT);
  pinMode(bottom,INPUT);
  Serial.println("awad software s");
  Serial.print("the ip adress is ");
 // Serial.println(Ethernet.localIP());
   
}
void loop()
{
  


val = digitalRead(bottom);
if(val == HIGH)
{
  digitalWrite(led,HIGH);
}
else
{
  digitalWrite(led,LOW);
}
    /*
  if(client.connect(server, 80))
  
  {
    digitalWrite(led,HIGH);
    Serial.println("-> connected");
    client.println( "GET /get/get.php?go=&submit=on HTTP/1.1");
    client.print( "Host: ");
    client.println(server);
    client.println( "connection: close" );
    client.println();
    client.println();
    //
    client.println( "GET /get/get.php?go=&submit1=off HTTP/1.1");
    client.print( "Host: ");
    client.println(server);
    client.println( "connection: close" );
    client.println();
    client.println();
    client.stop();

  }
  delay(1000);
  */
}

as you can see its an switch ..
with led
when i press the button the led lighting ..
and thats good
but when i active the ethernet
like this one

// Ethernet.begin(mac, ip);
// Serial.println(Ethernet.localIP());

or this one

  /*
  if(client.connect(server, 80))
  
  {
    digitalWrite(led,HIGH);
    Serial.println("-> connected");
    client.println( "GET /get/get.php?go=&submit=on HTTP/1.1");
    client.print( "Host: ");
    client.println(server);
    client.println( "connection: close" );
    client.println();
    client.println();
    //
    client.println( "GET /get/get.php?go=&submit1=off HTTP/1.1");
    client.print( "Host: ");
    client.println(server);
    client.println( "connection: close" );
    client.println();
    client.println();
    client.stop();

  }
  delay(1000);
  */

its working and send the data to the mysql server ..
but if i active anyone from this code
the led and the botton not working ..
it will not let me open or close the led light ..
why is that ..
thank you ..

upppppp

but if i active anyone from this code
the led and the botton not working ..
it will not let me open or close the led light ..
why is that ..

On a typical arduino with an ethernet shield, pin 13 is used by the ethernet shield as a timing pin. If you look at the LED in darkness it appears to be dimly glowing as the timing pulses are flashing it a little bit. You will need to chose another pin for controlling things.