Ethernet POE board fails after 3 hours

I've got an Ethernet POE shield mounted to an Arduino UNO R3 board and I am trying to build an environmental monitoring system with satellite Arduino's around my house that send data back to my mySQL server, and all powered off of POE.

So far everything has worked fine. My first module sat quite happily for a month sending temperature data back to the server, until one day there was a brief power cut (3secs) at my house and after that it ceased working.

I have a surge protector infront of my server cabinet which runs my switch, server etc.

The switch is a LevelOne GSW-2693 which says it is: 24 port IEEE802.3af PoE, Endpoint with 48VDC power through RJ-45 pin 1, 2, 3, 6 with Powered Device(PD) auto detection and classification. so it should be compatible with the Arduino POE sheild.

I have changed the UNO for a new one but at my last attempt the device lasted for 3 hours before it stopped sending data and instead it makes a faint buzzing noise. I haven't tried changing the ethernet POE board yet, but don't want to damage it incase there is something wrong I'm doing with the switch, even though it says its compatible.

Any suggestions greatly appreciated.

Thanks Matt

I don't have much experience with the PoE module specifically although I do work with on-board power supplies quite a bit.

What jumps out is the faint buzzing, to me that sounds like you may have a weak short somewhere. Make sure the PoE module is connected properly and none of the components are touching anything on the arduino.