Ethernet Shield & Analog pin

Salve

Sto provando una ethernet shield che mi è arrivata proprio oggi.... funziona quasi tutto regolarmente, si interfaccia al web... l'ho provata con pachube e funge.

L'unica cosa che proprio non riesco a capire è questa:
Ho un lm35 che ho utilizzato su arduino senza shield e mi da la tempertura giusta.... appena monto la ethernet shield con il medesimo codice mi da valori intorno a 480...

Perchè?

Il codice che seguo è questo:

void setup()
{
  Serial.begin(9600);
}

void loop()
{

  int analogPin=0;
  int sensor =0;
  sensor = analogRead(analogPin);
  sensor = (5.0 * sensor * 100.0)/1024.0;
  Serial.print("Temperatura: ");
  Serial.println(sensor);
  delay(500);
}

Forse ho risolto... guardando la pcb ho notato che A0 e A1 sono usati dalla SD... come posso recuperarli?

Credo di essere uno tra i pochi che fa le domande e si da le risposte da solo.
Scrivo la soluzione anche per gli altri ragazzi che hanno il mio stesso problema...
fonte: http://www.arduino.cc/cgi-bin/yabb2/YaBB.pl?num=1289348130

basta tagliare la tracce A0 e A1 che vanno alla SD.
a0 e a1 servono per qualcosa che ha a che fare con la protezione in scrittura della sd...

skaxxo:
Credo di essere uno tra i pochi che fa le domande e si da le risposte da solo.
Scrivo la soluzione anche per gli altri ragazzi che hanno il mio stesso problema...
fonte: http://www.arduino.cc/cgi-bin/yabb2/YaBB.pl?num=1289348130

basta tagliare la tracce A0 e A1 che vanno alla SD.
a0 e a1 servono per qualcosa che ha a che fare con la protezione in scrittura della sd...

tranquillo non sei l'unico. Ottimo lavoro, sarà sicuramente utile, già tempo addietro mi pare di aver letto una problematica simile

skaxxo:
Credo di essere uno tra i pochi che fa le domande e si da le risposte da solo.

Forse sei uno dei pochi che scrive subito la domanda, poi pensa e poi trova la risposta che pubblica sucessivamente. :wink: :wink: :wink:

skaxxo:
Scrivo la soluzione anche per gli altri ragazzi che hanno il mio stesso problema...
fonte: http://www.arduino.cc/cgi-bin/yabb2/YaBB.pl?num=1289348130

basta tagliare la tracce A0 e A1 che vanno alla SD.
a0 e a1 servono per qualcosa che ha a che fare con la protezione in scrittura della sd...

I connettori per le schedine SD hanno 2 interuttori, uno per vedere la presenza della schedina SD e l'altro vede la posizione del interruttore di protezione scrittura della schedina.
Tutti due non sono vitali.

Ciao Uwe

uwefed:
I connettori per le schedine SD hanno 2 interuttori, uno per vedere la presenza della schedina SD e l'altro vede la posizione del interruttore di protezione scrittura della schedina.
Tutti due non sono vitali.

Infatti....

Ora stavo meditando su come poter riutilizzare A0 e A1 senza tagliare le strisce... ho visto un paio di pad stagnabili... chissà se con una punta di stagno posso riutilizzarli... ma credo proprio di no.