ethernet shield con Arduino hecho en casa

Hola, Estoy tratando de usar la shield ehternet con un arduino casero ( atmega328, clistal, regulador, etc).

Tengo que mandarle 3v3 a la shield ethernet por el pin que se econta al 3v3 del arduino original? o solo mandandole 5v por el pin de arduino ya alcanza? Ella convierte los 5v en 3v3? o tengo que mandarselos?

Mi pregunta basicamente seria: ¿ cuales son los puntos de contacto entre el ardunio y el shield que necesita la shield para funcionar. ( ademas de los ICSP, 10,11,12,13,4 )

gracias!

Hola,

Tienes el esquema de la shield disponible en: http://arduino.cc/en/uploads/Main/arduino-ethernet-shield-schematic.pdf http://www.arduino.cc/en/Main/ArduinoEthernetShield

Hay tienes los pines que usa.

Saludos, ;)

Igor R.

Si, lo vi, pero no entiendo si genera los 3v3 o si los toma de la arduino. tampoco dice explicitamente que pines se conectan con el arduino.

gracias!

Si dice que pines se conectan. Si te fijas, los conectores J1, J2, .... son los que se insertan sobre la placa de Arduino. Es decir, tienes que mirar a que pines del micro, le corresponden los de la placa: http://www.arduino.cc/en/Hacking/PinMapping o http://arduino.cc/en/uploads/Main/Arduino-Diecimila-schematic.pdf

Tambien en el esquema se ve que hay un regulador 3V3 en la placa (arriba del todo)....

Solo tienes que pensar, que la placa de Arduino, se conecta con la shield a traves de los conectores J1,J2,...(4) es decir, tienes todo!!! :D

;)

haa me desconcerto que no diga a que pertenece cada jumper. Asumo que JI son los 8 pines del d8 al href. J2 los 6 analogicos y J3 los 8 pines desde el d0 al d8.

osea se conectan casi todos! jaja lpm, pense que solo tenia que conectar los del ICSP, pero parece que hay mas... primero voy a intentar sin conectar los analogicos y los del J3, que creo que son para manejar la SD, y no lo necesito.

Y segun el jumper "power" tengo que coenctarlo al 3v3 de arduino. Pero vos me decis que hay un regulador 3v3... entonses quedo aun mas desconcertado. Si no le mando 3v3, se quemara algo? o como mucho no funcionara? puedo probar no madnarle y listo a ver si funciona.

Muchas gracias igor!

Ya está. Dejo aca para referencia futura:

*Funciona sin mandarle 3v3. alcanza con los 5v solos y ella los convierte. *No funciona si conectas solamente los 13,12,11 digitales del shield a sus respectos atmega, sin conectar los del soket ICSP del shield a sus respectivos en el atmega. *Funciona conectando solo los 3 del ICSP del shield: miso,mosi,sck a los respectivos digitales en el atmega. Sin conectar los 13,12,11 del shield al atmega. *( resumiendo los dos puntos anteriores: los que hay que conectar al atmega son los del soket ICSP del shield, y no necesariamente los del jumper J1. solo el 10 del Jumper J1 y el ground ) * no funciona sin interconectar el digital 10. * funciona sin conectar el digital 4. * no funciona si no se le le manda ground en el pin al lado del href.

gracias!

salu3

Me alegro que te funcione!!

Se me ha olvidado comentar antes,que hay dos versiones de shield de ethernet… El link que te he puesto antes, es de la primera.

Aquí pongo el más nuevo (que debe ser el que tienes tu, que es compatible con el Arduino Mega, y por eso no deben estar enrutados los pines 11,12 y 13 en el conector de la shield con los pines SPI).

La placa de Arduino Mega, tiene el bus SPI en pines diferentes, y por eso luego hicieron otra versión… a parte de añadirle lector de tarjetas.

Pero vaya, yo sólo me lo he mirado por encima rápidamente, así que tampoco puedo asegurar nada… Yo no tengo la shield, lleva por debajo conector hembra para encajar con los pines ICSP de las placas Arduino??

:wink:

exelente.

si lleva el conector!

gracias de nuevo