ethernet shield not working

Hi,
I have a duemilanove and an ethernet shield. I just need to get some data from a php page but I can’t even run the webclient example…it won’t print anything in the serial monitor. My router has dhcp enabled and I tried both with and without static ip…I tried also to change randomly the MAC but didn’t work…what it might be?

this is the code I’m using

/*
  Web client

 This sketch connects to a website (http://www.google.com)
 using an Arduino Wiznet Ethernet shield.

 Circuit:
 * Ethernet shield attached to pins 10, 11, 12, 13

 created 18 Dec 2009
 by David A. Mellis
 modified 9 Apr 2012
 by Tom Igoe, based on work by Adrian McEwen

 */

#include <SPI.h>
#include <Ethernet.h>

// Enter a MAC address for your controller below.
// Newer Ethernet shields have a MAC address printed on a sticker on the shield
byte mac[] = { 0x90, 0xA2, 0xDA, 0x10, 0x0B, 0x80 };
// if you don't want to use DNS (and reduce your sketch size)
// use the numeric IP instead of the name for the server:
//IPAddress server(74,125,232,128);  // numeric IP for Google (no DNS)
char server[] = "www.google.com";    // name address for Google (using DNS)

// Set the static IP address to use if the DHCP fails to assign
IPAddress ip(192, 168, 0, 199);

// Initialize the Ethernet client library
// with the IP address and port of the server
// that you want to connect to (port 80 is default for HTTP):
EthernetClient client;

void setup() {
  // Open serial communications and wait for port to open:
  Serial.begin(9600);
  while (!Serial) {
    ; // wait for serial port to connect. Needed for native USB port only
  }

  // start the Ethernet connection:
  if (Ethernet.begin(mac) == 0) {
    Serial.println("Failed to configure Ethernet using DHCP");
    // try to congifure using IP address instead of DHCP:
    Ethernet.begin(mac, ip);
  }
  // give the Ethernet shield a second to initialize:
  delay(1000);
  Serial.println("connecting...");

  // if you get a connection, report back via serial:
  if (client.connect(server, 80)) {
    Serial.println("connected");
    // Make a HTTP request:
    client.println("GET /search?q=arduino HTTP/1.1");
    client.println("Host: www.google.com");
    client.println("Connection: close");
    client.println();
  } else {
    // if you didn't get a connection to the server:
    Serial.println("connection failed");
  }
}

void loop() {
  // if there are incoming bytes available
  // from the server, read them and print them:
  if (client.available()) {
    char c = client.read();
    Serial.print(c);
  }

  // if the server's disconnected, stop the client:
  if (!client.connected()) {
    Serial.println();
    Serial.println("disconnecting.");
    client.stop();

    // do nothing forevermore:
    while (true);
  }
}

thanks :confused:

I just need to get some data from a php page

At www.google.com?

What output do you get from that code?

no, sorry I wasn't clear..In future I will need to have the ethernet sheild to get data from a php page..right now I'm just trying to set it up and understand how it works...however, the previous code don't do anything (nothing is printed into the serial monitor)..same for other similar example that I tried..

however, the previous code don't do anything (nothing is printed into the serial monitor)..same for other similar example that I tried..

Hmmm...

I have a duemilanove

and

  while (!Serial) {
    ; // wait for serial port to connect. Needed for native USB port only
  }

Why? Why do you have that code? That is needed only for the Leonardo, Micro, and Due.

ok I didn't know about the Leonardo thing..however I deleted it..but it still prints nothing..

thanks

and an ethernet shield

What type? There is more than one.

oh ok..it should be this one https://cdn.sparkfun.com/assets/parts/6/6/4/3/11166-01.jpg

You need to use a library that is compatible with the w5500, or at least a w5200.

ok thanks..when I purchased it I thought it was the original shield.. :angry:

Here are some options for W5500 compatible Ethernet libraries: https://github.com/adafruit/Ethernet2 https://github.com/Wiznet/WIZ_Ethernet_Library https://github.com/per1234/EthernetMod/tree/W5x00

Hi, thanks…I found them…however I purchased an original one a few days ago so I’m using that one with the normal library…thanks :slight_smile: