Ethernet shield on Arduino pro

Been busy developing a little project on a Arduino Duemilanove with a 168, all working fine. However if I plug the ethernet board into an Arduino pro (from spark fun) everything works except the ethernet :-/

Now, the Arduino pro has a 328 on board, so I tried my Duemilanove with a DIP 328, and that worked perfectly. Still no go on the pro board though.

I haven't got another SPI device I can easily test with.

Any ideas chaps?

Ok guys, I've got it figured out, and I believe I have uncovered a problem with the ethernet shield.

http://www.youtube.com/watch?v=AiBU8N4byLE http://www.youtube.com/watch?v=AiBU8N4byLE

The pin that would normally connect to the 3.3v output of the FTDI chip on the official Arduino boards actually connects to 5v on the 5v Sparkfun board! While this is more of a Sparkfun issue, theres another side effect, if theres a voltage difference between the FTDI chip and the regulator, it's quite possible for the regulator to cause harm to the FTDI, this, in my and my dads opinion really isn't a brilliant idea.

In the video you can see I cut the track between the 3.3v regulator and the 3v3 pin, this allows the system to run perfectly.