Ethernet Shield Problems

I have an Arduino R3, and an Ethernet shield, the Arduino unit appears to be working correctly, but the ethernet shield does not. The Power led is on and the green pin 13 led is flickering, but the indicator lights on the ethernet port are not lighting, even when tried with multiple cables, i have tried multiple different tests and they all show failed to get an IP address using DHCP or something along those lines, any help would be greatly appreciated!

IMG_2047.JPG

Looks like there are solder bridges on that IC. There should be no solder bridges on a properly assembled board. Can you provide a closeup pic of just the w5100?

That is a w5100, correct?

This is my very first arduino project, so i’m sorry if i’m not the easiest to deal with.

If you have the CAT5 cable connected to a computer or router, and have no lights lit on the RJ45 connector, then there is something wrong with the ethernet side of the w5100.

So would the easiest thing to do would be is to return it?

If you are certain everything is ok with the CAT5 cable and the computer/router, then probably returning it for a replacement is the best thing to do.

You can try this test code. It tests the SPI side of the w5100. If the serial monitor shows 192.168.2.2, then the SPI bus and the SPI side of the w5100 is ok. If it shows anything else, the SPI bus has failed.

#include <SPI.h>
#include <Ethernet.h>

byte mac[] = {  0xDE, 0xAD, 0xBE, 0xEF, 0xFE, 0xED };
IPAddress ip(192,168,2,2);

void setup() {
  Serial.begin(9600);

  // disable SD SPI
  pinMode(4,OUTPUT);
  digitalWrite(4,HIGH);

  // Start ethernet
  Serial.print(F("Starting ethernet..."));
  Ethernet.begin(mac, ip);
  Serial.println(Ethernet.localIP());
}

void loop() {
}

The only thing the serial monitor reads is: StaStarting ethernet...0.0.0.0

Then the w5100 is not responding on the SPI bus. Insure the ethernet shield is connected to the Arduino ok. The ICSP pins are the most important. That is how the SPI bus data lines connect to the shield.

If you are sure the shield pins are inserted fully and properly into the Arduino, then returning it for a replacement is what I recommend.