Ethernet Shield

Hi Leute,
ich arbeite seit heute mit dem Ethernet Shield 2 und möchte den Ad über eine Website steuern. Dafür hab ich den Beispielcode "Teleduino328EthernetClientProxy" von der Lib "Teleduino328" genommen aber mir wird die ganze Zeit angezeigt das die Verbindung zum server noch aufgebaut wird. Das komische ist ich hatte am anfang immer wieder verbindung konnte aber nichts senden. Ich dachte ers ich hätte perfomenz probs wegen speicher aber als ich einen anderen Ad mit mehr Speicher genommen habe fing es mit meinem prob an. Auch als ich wieder den anderen Ad wieder genommen habe klappte es nicht.

Zur Schaltung:
Ich habe eine Led um zu sehen ob eine Verbindung aufgebaut wird oder wenn es probleme mit dem Internet oder mit dem Schlüssel gibt an pin 8 angeschlossen.
Eine weitere an einen beliebigen pin um zu sehen ob der Ad auch das gesendete Signal richtig ausgibt.

Grüße aus der Eifel :slight_smile:

Ein Erfahrungsbericht?

Hi und welcome in diesem Forum
(als Auch-Eifeler ein besonderes “Jooden Daach”),

zu deinem Thema:

Wenn du Hilfe brauchst, dann wäre es sehr hilfreich, wenn du folgende Infos zur Verfügung stellst:

  1. wie sieht deine Hardware (insbes. auch welcher Arduino und welche shields o.ä.) und die Verdrahtung dazu aus (einfache, aber aussagekräftige Handskizze ist ausreichend und meist besser als super duper Foto mit vielen bunten Drähtchen deren Ursprung und Endpunkt man entweder gar nicht erkennt oder nur erraten kann)

  2. wie sieht dein Ardu-Sketch aus (bitte code tags </> benutzen)

  3. was GENAU ist dein Problem, was tut es / was tut es nicht und ggf. unter welchen Randbedingungen?

Mit diesen Infos erspart man sich viele Rückfragen, Missverständnisse etc. und kommt schneller auf den Punkt.

Die Leute hier sind gerne bereit, Ihr Wissen zu teilen, aber dazu muss auch der Hilfesuchende etwas mehr beitragen - bitte nicht falsch verstehen - als zu sagen, ich habe da mal ein Problem und es klappte vorher und jetzt nicht mehr …

Da wir das hier alles in unserer Freizeit und unentgeltlich machen und auch die Karma-Punkte nirgendwo wirklich eintauschbar sind, ist die Bereitschaft, sich mit einem Thema auseinanderzusetzen, nur dann besonders hoch, wenn man sofort erkennen kann, ob man aus eigener Erfahrung etwas beitragen kann.

grad hatte ich wieder verbindung aber jetzt hab ich ein anderes Problem. Diese meldung bekomm ich die ganze Zeit auch wenn ich einen komplet anderen Sketch lade:
"WARNING: Spurious .github folder in 'Ethernet2' library"
Wenn ihr mir dabei geholfen habt kennt sich einer mit Teleduino aus? Hier ist der link der Seite: https://www.teleduino.org
Mit der Seite kann man den Ad über internet steuern doch mein Ad gibt nix aus liegt wohl an dem zuvor beschriebenen Problem.

Grüße aus der Eifel

Na wenigstens ist diesmal ein Fragezeichen.

Wenn ihr mir dabei geholfen habt kennt sich einer mit Teleduino aus?

Eins nach dem anderem, erst wird dir geholfen und dann werden dir deine Fragen beantwortet.

Kennst du den Fehler? Denn jetzt hab ich wieder das Problem vom Anfang bei klappt was düfür dann was anderes wieder nicht und das immer so weiter seit ich mit Teleduino angefangen habe:(

Sorry,
ich weiß, wir Eifeler sind stur, aber wir sollten nicht ignorant sein.

Lies dir doch bitte nochmal meine erste Antwort durch und befolge die Punkte 1-3 und bitte in etwas besser lesbarer Form; ich weiß aus eigener Erfahrung, dass auch in Eifeler Schulen Satzzeichen gelehrt und angewendet werden.

Dann wird dir hier besser geholfen, da wir dann auch dein Problem leichter verstehen sollten.

Das Arduino Ethernet Shield 2 wird von arduino.org produziert (hier ist das Forum von arduino.cc) Arduino - Home
Damit Du es benuzen kannst, mußt Du die IDE, Bibliotheken bzw Sketche von arduino.org verwenden, da arduino.cc kein Shield mit dem Ethernet Controller W5500 hat.

Grüße Uwe