Ethernetmodul ENC28J60

Hallo,

ich versuche folgendes Ethernetmodul zum laufen zu bringen,

http://www.dx.com/p/jy-mcu-enc28j60-ethernet-module-blue-166604

dazu benutze ich folgende Bibliothek.

https://github.com/jcw/ethercard

so wie dort angegeben habe ich den Anschluss gemacht, jeweils mit einem Nano und einem Mega2560. danach eines der bsp. ausprobiert, doch leider ohne Erfolg.

Hat jemand Erfahrung mit diesen Modulen und kann mir einen Tipp geben?

Ich habe auch schon eine externe Spannungsquelle angeschlossen weil ich dachte,dass das Modul zuviel Strom benötigt , leider führte das auch nicht zum Erfolg.

Das Modul funktioniert soweit, denke ich, nur die ethernetconnection will nicht klappen. Mit dem W5100 Chip funktioniert die Verbindung zu meinem Router.

nimm die UIPEthernet lib, die ist mit der Ethernet der IDE kompatibel. Anschlüsse 50-53 beim MEGA2560, soweit ich glaube. habe es im Einsatz

schau mal den Preis hier

Diese lib hier https://github.com/renatoaloi/Enc28CoreLib/wiki wäre auch mal einen Versuch wert

also ich habe jetzt mal diverse libaries für den chip getestet, ohne Erfolg.

folgende Verdrahtung habe ich gemacht:

VCC - 3.3V
GND - GND
SCK - Pin 13
SO - Pin 12
SI - Pin 11
CS - Pin 8 / 10 je nach verwendeter lib.

mit einem Nano. Der Switch an dem der enc28j60 hängt, zeigt auch eine Verbindung mit halfduplex 10mbit an.
Das war es dann aber auch schon, ich bekomme keine Verbindung über dhcp oder fester ip, keines der mitgelieferten bsp funktioniert. Ich habe es auch mit zwei verschiedenen chips probiert.
Am selben Anschluss funktioniert es mit dem W5100 Chip wunderbar, aber es muss an meinem Setup liegen, bei anderen geht es ja. Hat jemand noch eine Idee?

hast du keinen Uno zum testen, ob es mit deinen ENC28J60 grundsätzlich überhaupt geht?

Ob Nano/Uno oder einem nackten Atmega328P spielt hier keine Rolle. Poste bitte mal deinen Sketch