eventuale guasto scheda Arduino

salve a tutti :slight_smile:

da poco un mio amico mi ha regalato un scheda Arduino UNO rev.3, ancora chiuso nella scatola :slight_smile:

Ho provato a caricarli un programma e mi dava un errore strano...
allora ho provato a caricarli il classico programma , ovvero "Blink" , e l'errore persiste...
Non vorrei che la scheda sia nata fallata...

errore che mi segnala :

avrdude: verification error, first mismatch at byte 0x0000
0xff != 0x0c
avrdude: verification error; content mismatch

e continua a scrivermi : "sto caricando"...

premesso che al momento del click sul pulsante di caricamento i led on board blinkano come se il programma venisse caricato... e poi segnala l'errore sopra citato...

sapete se è un problema comune ? E' risolvibile?

grazie per l'attenzione

MD

Pensando che sia un problema di Bootloader, ho provato a ricaricarglielo...
ma anche quando vado a scrivere il bootloader...
da lo stesso errore...

presumo proprio che sia il chip ATmega che non funziona....

Però la scatola era sigillata, MAI usato... Capita ovvio...
ma con lo scontrino in mano, esiste un posto per poterlo sostituire? dal momento che è nato male?

MD

Pensando che sia un problema di Bootloader, ho provato a ricaricarglielo

E come hai fatto a provare a ricaricare il bootloader ?

usando il tutorial ufficiale:

MD

Ah, pensavo che tu non avessi un'altra scheda Arduino

Per ricaricare il Bootloader Ti servono 2 Arduini. Ne hai?
Hai selezionato nel IDE il Arduino giusto ( Arduino SMD e Arduino normale sono 2 schede diverse)

Ciao Uwe

si si fatto tutto....
ho provato a cambiare l'integrato Atmega , e la scheda funziona dinuovo....
comprerò un altro integrato... dato il costo di 7 euro circa

MD

A 7€ è un furto!

https://www.ebay.it/itm/291952785268

grazie per il link :slight_smile:

Si comunque avevo sparato una cifra così... non conoscevo il reale costo.... era per rendere l'idea :slight_smile:

grazie a tutti :slight_smile:

MD