Example Arduino 1.0

L'example Arduino 1.0 webclient ne marche pas chez moi. J'utilise un hub ethernet sur lequel sont connectés, la box, un PC et l'arduino, quand je charge webclient sur arduino, je ne lit rien dans le moniteur, l'adresse mac est bien celle de l'arduino, quand je déclare une IP adresse à l'arduino, je le ping bien, quelqu'un a une idée. Merci

CORBEL:
J’utilise un hub ethernet sur lequel sont connectés, la box, un PC et l’arduino, quand je charge webclient sur arduino, je ne lit rien dans le moniteur, l’adresse mac est bien celle de l’arduino, quand je déclare une IP adresse à l’arduino, je le ping bien, quelqu’un a une idée.

A tu essayé d’ajouter les arguments gateway et subnet à Ethernet.begin() ?
(cf http://arduino.cc/it/Reference/EthernetBegin)

De base l’exemple webclient est fait pour marcher avec la ethernet shield connecté directement à l’ordinateur sans routeur / hub.

Je vais regarder ton lien, mais si je me connecte directement sur le PC, je ne peux pas me connecter à google comme dans l'exemple, faut il un serveur web sur le PC avec une page qui renvoit des indos à l'arduino ?

CORBEL: Je vais regarder ton lien, mais si je me connecte directement sur le PC, je ne peux pas me connecter à google comme dans l'exemple, faut il un serveur web sur le PC avec une page qui renvoit des indos à l'arduino ?

Les exemples mériterai une bonne mise à jour, en partie à cause de ce genre de contradiction. En plus avec le DHCP disponible depuis la version 1.0 dans la lib ethernet il y aurait plein de chose à revoir dans les exemples.

Merci

L'exemple client fonctionne, j'ai mis ma freebox en routeur et les exemples fonctionnent correctement. RESOLU