exec : "cmd.exe"; executable file not found in %PATH% ESP8266

Hi,

error occur when i try to run code into ESP8266

exec: "cmd.exe"; executable file not found in %PATH%
Error compiling for board Generic ESP8266 Module

Thanks

Please do this:

  • File > Preferences > Show verbose output during: > compilation (check) > OK
  • Sketch > Verify/Compile
  • After the compilation fails you’ll see a button on the right side of the orange bar “Copy error messages”. Click that button.
  • Paste the error messages in a reply here USING CODE TAGS (</> button on the forum toolbar).

If the length of the output exceeds the forum’s 9000 character limit, save it in a txt file and post it here as an attachment. If you click the “Reply” button you’ll see the “Attachments and other options” link.

I found the solution, in boards manager go to esp8266, click on it, select version -> 2.4.2 and install. The higher versions of esp8266 don't work properly!!

i still get the same error even if i already installed the lower version.

pls check verbose error attached.

esp8266CompileError.txt (17.2 KB)

The output in your attachment shows you're still using version 2.5.0:

Using board 'generic' from platform in folder: C:\Program Files (x86)\Arduino\hardware\esp8266-2.5.0\esp8266-2.5.0