Executing Command: Exit status 1

Example Blink from Web Platform does not compile. My sketches does not compile.
Same setup on IDE 1.06 - all compile and OK

Setup:

Arduino nano - clone CH340, checked on IDE 1.06. on the same setup, same sketches - OK.

  • Windows 7 home
  • Chrome
  • Arduino IDE on the same PC (working OK)
  • extension cable on USB port

Before Web editor, my boards were on port 15 on IDE. For unknown reasons, the Web Editor sets port 19 (no other ports offered). When I came back to IDE, the IDE prompted me there was no board of port 15. I changed the port in IDE to port 19 as well and the IDE successfully uploads the sketch afterwards.

Attempts to solve

I re-downloaded and re-installed the CreateAgent three times. After first install other errors appeared in the compiling phase - I do not remember which ones.

I screened the forum - from my understanding, I could not see a solution for my dead end.

I re-select the board and port 5 times in Web Editor.

I ran out of ideas where to look. Please help.

See bellow full verbose:

./opt/arduino-builder/arduino-builder -compile -core-api-version 10611 -build-path /tmp/691392506/build -hardware opt/arduino-builder/hardware -hardware ./opt/cores -tools opt/arduino-builder/tools -tools ./opt/tools -built-in-libraries opt/libraries/latest -libraries /tmp/691392506/pinned -libraries /tmp/691392506/custom -fqbn arduino:avr:nano:cpu=atmega328 -build-cache /tmp -logger humantags -verbose=true /tmp/691392506/Blink

Using board 'nano' from platform in folder: /home/admin/builder/opt/cores/arduino/avr

Using core 'arduino' from platform in folder: /home/admin/builder/opt/cores/arduino/avr

Detecting libraries used...

"/home/admin/builder/opt/tools/avr-gcc/4.9.2-atmel3.5.4-arduino2/bin/avr-g++" -c -g -Os -w -std=gnu++11 -fpermissive -fno-exceptions -ffunction-sections -fdata-sections -fno-threadsafe-statics -MMD -flto -w -x c++ -E -CC -mmcu=atmega328p -DF_CPU=16000000L -DARDUINO=10611 -DARDUINO_AVR_NANO -DARDUINO_ARCH_AVR "-I/home/admin/builder/opt/cores/arduino/avr/cores/arduino" "-I/home/admin/builder/opt/cores/arduino/avr/variants/eightanaloginputs" "/tmp/691392506/build/sketch/Blink.ino.cpp" -o "/dev/null"

Generating function prototypes...

"/home/admin/builder/opt/tools/avr-gcc/4.9.2-atmel3.5.4-arduino2/bin/avr-g++" -c -g -Os -w -std=gnu++11 -fpermissive -fno-exceptions -ffunction-sections -fdata-sections -fno-threadsafe-statics -MMD -flto -w -x c++ -E -CC -mmcu=atmega328p -DF_CPU=16000000L -DARDUINO=10611 -DARDUINO_AVR_NANO -DARDUINO_ARCH_AVR "-I/home/admin/builder/opt/cores/arduino/avr/cores/arduino" "-I/home/admin/builder/opt/cores/arduino/avr/variants/eightanaloginputs" "/tmp/691392506/build/sketch/Blink.ino.cpp" -o "/tmp/691392506/build/preproc/ctags_target_for_gcc_minus_e.cpp"

"/home/admin/builder/opt/arduino-builder/tools/arduino-preprocessor/0.1.5/arduino-preprocessor" "/tmp/691392506/build/preproc/ctags_target_for_gcc_minus_e.cpp" "" -- -std=gnu++11

Compiling sketch...

"/home/admin/builder/opt/tools/avr-gcc/4.9.2-atmel3.5.4-arduino2/bin/avr-g++" -c -g -Os -w -std=gnu++11 -fpermissive -fno-exceptions -ffunction-sections -fdata-sections -fno-threadsafe-statics -MMD -flto -mmcu=atmega328p -DF_CPU=16000000L -DARDUINO=10611 -DARDUINO_AVR_NANO -DARDUINO_ARCH_AVR "-I/home/admin/builder/opt/cores/arduino/avr/cores/arduino" "-I/home/admin/builder/opt/cores/arduino/avr/variants/eightanaloginputs" "/tmp/691392506/build/sketch/Blink.ino.cpp" -o "/tmp/691392506/build/sketch/Blink.ino.cpp.o"

Compiling libraries...

Compiling core...

Using precompiled core: /tmp/core/core_arduino_avr_nano_cpu_atmega328_0aa5caef1c8d4449182adee8bd94fca7.a

Linking everything together...

"/home/admin/builder/opt/tools/avr-gcc/4.9.2-atmel3.5.4-arduino2/bin/avr-gcc" -w -Os -g -flto -fuse-linker-plugin -Wl,--gc-sections -mmcu=atmega328p -o "/tmp/691392506/build/Blink.ino.elf" "/tmp/691392506/build/sketch/Blink.ino.cpp.o" "/tmp/691392506/build/../../core/core_arduino_avr_nano_cpu_atmega328_0aa5caef1c8d4449182adee8bd94fca7.a" "-L/tmp/691392506/build" -lm

"/home/admin/builder/opt/tools/avr-gcc/4.9.2-atmel3.5.4-arduino2/bin/avr-objcopy" -O ihex -j .eeprom --set-section-flags=.eeprom=alloc,load --no-change-warnings --change-section-lma .eeprom=0 "/tmp/691392506/build/Blink.ino.elf" "/tmp/691392506/build/Blink.ino.eep"

"/home/admin/builder/opt/tools/avr-gcc/4.9.2-atmel3.5.4-arduino2/bin/avr-objcopy" -O ihex -R .eeprom "/tmp/691392506/build/Blink.ino.elf" "/tmp/691392506/build/Blink.ino.hex"

"/home/admin/builder/opt/tools/avr-gcc/4.9.2-atmel3.5.4-arduino2/bin/avr-size" -A "/tmp/691392506/build/Blink.ino.elf"

Sketch uses 928 bytes (3%) of program storage space. Maximum is 30720 bytes.

Global variables use 9 bytes (0%) of dynamic memory, leaving 2039 bytes for local variables. Maximum is 2048 bytes.

Flashing with command:C:/Users/Florin/.arduino-create/arduino/avrdude/6.3.0-arduino9/bin/avrdude.exe -CC:/Users/Florin/.arduino-create/arduino/avrdude/6.3.0-arduino9/etc/avrdude.conf -patmega328p -carduino -PCOM19 -b115200 -D -Uflash:w:C:/Users/Florin/AppData/Local/Temp/arduino-create-agent076586409/Blink.hex:i

avrdude: stk500_recv(): programmer is not responding

avrdude: stk500_getsync() attempt 1 of 10: not in sync: resp=0x16

avrdude: stk500_recv(): programmer is not responding

avrdude: stk500_getsync() attempt 2 of 10: not in sync: resp=0x16

avrdude: stk500_recv(): programmer is not responding

avrdude: stk500_getsync() attempt 3 of 10: not in sync: resp=0x16

avrdude: stk500_recv(): programmer is not responding

avrdude: stk500_getsync() attempt 4 of 10: not in sync: resp=0x16

avrdude: stk500_recv(): programmer is not responding

avrdude: stk500_getsync() attempt 5 of 10: not in sync: resp=0x16

avrdude: stk500_recv(): programmer is not responding

avrdude: stk500_getsync() attempt 6 of 10: not in sync: resp=0x16

avrdude: stk500_recv(): programmer is not responding

avrdude: stk500_getsync() attempt 7 of 10: not in sync: resp=0x16

avrdude: stk500_recv(): programmer is not responding

avrdude: stk500_getsync() attempt 8 of 10: not in sync: resp=0x16

avrdude: stk500_recv(): programmer is not responding

avrdude: stk500_getsync() attempt 9 of 10: not in sync: resp=0x16

avrdude: stk500_recv(): programmer is not responding

avrdude: stk500_getsync() attempt 10 of 10: not in sync: resp=0x16

avrdude done. Thank you.

Update:

  • change 3 cables, 2 of them absolutely new.
  • connect cable to USB 2 (previously connected by mistake to USB 3.0)
  • connect the board directly to the USB of the PC
  • change port from `19 to 20.

Same result.

Do this:

  • From the board dropdown menu, select "Select other Board & Port"
  • Select "Arduino Nano"
  • Select "ATmega328old"
  • Click "OK"

After doing that, the problem should be solved.

@pert

I did it. First time, using Blink Example - successfully uploaded.

Then, after opening my sketch and selection of ATmega328old - the Creator keeps reverting on its own back to ATmega 328 and same error.

I clicked OK very carefully, three times.

Some times I got the message "Board disconnected" and "Board "unavailable". Then again goes back to ATmega328 by its own.

Did it several times in a row - first by select other board and then by changing it. Sometimes successfully uploaded some times not.

In the end, the Creator looked satisfied and allowed me to stay on the ATmegaold (:-)). I guess solving this issues has something to do with the order of selection of the board. My guess

Thank you, @pert! You are great!

But every time I restart the Creator the story repeats. Perhaps the self-detection identifies the Board as an ATmega328. Then it has to be changed manually.

I could try to see if this is true, but i do not know how to disable self-detection.

Well that's annoying, even more so because the interface doesn't clearly show you which "flavour" is selected so it's not obvious when it changes. I know that the Arduino Web Editor links the selected board with a sketch so if you change to a sketch that you previously had associated with Nano, ATmega328 then it will switch back to that processor selection. However, when you actually go into the board menu and select the ATmega328old "flavour" that should be linked to the sketch and it should remember that selection. I do notice that the little "Sketch .... now linked to Arduino Nano" notification that pops up when you change to a new board does not appear after changing flavours of the previously linked board. So maybe if you change to a different board, then back to the Nano, ATmega328old, it will make it stick. I just did some tests and was not able to reproduce the problem you're having.

(note my sketch is just a few lines for the moment, so it does nothing really, but is correct)

I closed the Creator.

I reopen it. My sketch shows a red x on the link to the Board.

I changed the Board to ATmega328old.

Successfully loaded.

After 2-3 minutes an yellow pop up appears: "No plugin connection". Dissapears.

I re-loaded my sketch. Successfully reloaded.

Wet to Basics -> Blink-> upload. OK

Back to my sketch -> loaded-> OK.

Look into Board: was set to ATmega 328!. Attempt to change to 328old. First time not successful. Second time OK,

That is more than frustrating. OK, eventually is working and uploading, but is annoying.

In my view, it would make more sense to give to user full control over the selection of the board. This self-detection function rised to me a lot more problems than I would have just attempting several times to select the right board.

The same idea goes for the option of linking the sketch to the Board.

Discussion of the non-persistent "flavour" issue to be continued at:
http://forum.arduino.cc/index.php?topic=535050