Extremely urgent -Arduino UNO r2 not detected.....

Hello! I was using my arduino UNO (official) r2 for a robotics project. After a night of hard work, i continued my work in the morning but the arduino would not get detected. I had used the same usb cable last night.

I would really appreciate the help as this is my 3rd arduino and being a student in a poor country (india) this is the last arduino i can afford to break :(

Here are the symptoms: 1) The Arduino is completely NOT detected. I have tried this on 2 laptops, both mac and win7. When the arduino is plugged in, the laptop does not detect ANYTHING! EDIT: On the last night that this UNO was working i randomly got this message a couple of times : avrdude: stk500_getsync(): not in sync but the issue usually resolved it self by plugging/replugging/reset button. 2) I have tried it with 2 USB cables. The USB cable which was working before has also stopped working 3) None of the uC's i.e 'MEGAU8 and 'MEGA328P get warm 4) Since the arduino is not detected at all, the loopback test cannot be performed 5) The previous sketch runs fine 6) When i connect the arduino to power (usb or external) the on board LED 13 blinks (i think it blinks 3 times though not sure)

Help is much appreciated as i have many competitons coming up :/

lol. you broke the other two? open device manager (control panel) and right click any where on one of the devices + click detect new hardware. migth be detected then. but since yo tried it on so many, i doubt it.

maybe a defective board as you say a cable you used topped working

Thanks for taking the time to reply but your reply was not very helpfull :/

qwerty156: Thanks for taking the time to reply but your reply was not very helpfull :/

Killing so many arduinos is not normal, what are you doing with them?

qwerty156: Thanks for taking the time to reply but your reply was not very helpfull :/

Please describe how you had these Arduinos connected to other devices. A wiring diagram would help. If you cannot afford to destroy a lot of Arduinos you should probably find out what you are doing wrong with them.

The first and the second arduino were broken in seperate projects looong time ago. Anyway, i had connected the arduino to a l293 motor driver - standard wiring nothing special. Never even once was 'magic smoke' released from any of the components. The whole robot still works as intended but i am unable to program it. I think that the megau8 is at fault here.... The TX light faintly glows. Also, i tried putting the arduino into DFU mode after it stopped working but i was unable to find how to set the UNO r2 into DFU mode. I tried shorting the first two wires of the ISCP connector as shown here: http://arduino.cc/en/uploads/Hacking/Uno-front-DFU-reset.png

but the arduino is still not detected at all.

You should be able to bypass the USB chip and program via the ICSP header. You need a programmer. You can buy something like the USBtinyISP for around $20, or just use another Arduino as the programmer.

[quote author=Nick Gammon link=topic=127050.msg964375#msg964375 date=1350764690] You should be able to bypass the USB chip and program via the ICSP header. You need a programmer. You can buy something like the USBtinyISP for around $20, or just use another Arduino as the programmer. [/quote]

Or 3.5 usd :D

http://www.ebay.com/itm/USBasp-USBISP-3-3V-5V-AVR-Programmer-USB-ATMEGA8-L-/140763404046?pt=LH_DefaultDomain_0&hash=item20c627170e

http://www.onlinetps.com/shop/index.php?main_page=product_info&products_id=596
Would this work?
or even this one:
http://www.onlinetps.com/shop/index.php?main_page=product_info&cPath=74_127&products_id=603

eried: Or 3.5 usd :D

http://www.ebay.com/itm/USBasp-USBISP-3-3V-5V-AVR-Programmer-USB-ATMEGA8-L-/140763404046?pt=LH_DefaultDomain_0&hash=item20c627170e

For those of us who are slow on the uptake, how is the 10-pin cable on that device connected to the 6-pin ICSP header?

Does it have to be that make of scissors or will almost any make do. XD

http://www.ebay.com/itm/USBASP-USBISP-AVR-Programmer-USB-10-Pin-Convert-to-Standard-6Pin-Adapter-Board-/180980285082?pt=LH_DefaultDomain_0&hash=item2a2343fe9a

There is a small adapter