"Failed to leave programmer mode" Cannot program any new arduinos with laptop

Ok so to start with I will say that I have 7 Arduino Mega 2560s running in a clean room environment. I have had no problems communicating with the first 6 of them. Upon installing the 7th I have hit a wall in being able to upload sketches. Every time I try to upload I get "failed to leave programmer mode" with no actual error codes. If I try any other new Mega it also fails in this same way. If I try to upload to one of the existing boards it runs perfectly, but I cannot implement another board into the system.

  • I have successfully uploaded to the same new boards using my desktop computer, but I NEED to be able to program the boards using that laptop in the clean room.

  • I have reinstalled the arduino software and board drivers

  • I have reset the com ports to test a possible accumulation of in use com ports with no success.

  • I have tried using various com ports, including ports that worked on the other boards.

  • I have tried uploading both my sketch and "blink" to them and neither of them will upload.

I know I have seen a few people having this problem on the web in other locations but have not found a successful solution. Any thoughts or ideas would be greatly appreciated. I will post updates as this progresses.

Thank you all in advance.

I swear this happens to me every time I post to a forum with a problem but it seems to be solved at this point. I tried uninstalling the driver again using the device manager. I then couldn't find where to download the driver itself from again so I decided to uninstall Arduino entirely again. When I went to reinstall it I got alot of errors "could not open this or that file" So I cancelled it, uninstalled it again and this time used CCcleaner to remove what I figured were lingering registries that were interfering with reinstalling the software. After running CCcleaner it installed perfectly and was able to communicate with the Mega like it should.

In the end I do not know what the problem actually was but it seems that running CCcleaner or a similar program was the solution to the problem.

With that said I still am not sure if this is completely solved the program as I have not tried to communicate with the other 6 Megas yet. I am afraid that when I go to connect with the 7th one I may experience this same problem. If I don't post again here it is safe to assume that the problem is solved however I will update if upon connecting to the 7th the problem resurfaces. For not though hopefully this will help anyone else who stumbles across a similar problem.

I recently had massive problems with upgrading to Solidworks 2015 from 2012 and it turned out it was because of duplicated registries so I am guess this is also the case here. Apparently I don't get along with registries.

Thanks for posting your solution. The Arduino IDE is not the best software, but is great for beginners.

Funny, I've never had issues updating Solidworks. It seems your pc doesn't like you very much!