Failing to make it work the SD card module!

Here are the setting :

I’ve tried both SD library and SdFat library and here are the output when running CardInfo from SD library:

Initializing SD card...Wiring is correct and a card is present.

Card type: SD2
Could not find FAT16/FAT32 partition.
Make sure you've formatted the card

And here is what I get when running SdInfo from SdFat:

SdFat version: 1.0.5

Assuming the SD is the only SPI device.
Edit DISABLE_CHIP_SELECT to disable another device.

Assuming the SD chip select pin is: 4
Edit SD_CHIP_SELECT to change the SD chip select pin.

type any character to start

init time: 613 ms

Card type: SD2

Manufacturer ID: 0X3
OEM ID: SD
Product: SD032
Version: 8.0
Serial number: 0XFFFFFFFF
Manufacturing date: 2/2006

cardSize: 1434381.75 MB (MB = 1,000,000 bytes)
flashEraseSize: 32 blocks
eraseSingleBlock: true
OCR: 0X80FF8000

SD Partition Table
part,boot,type,start,length
1,0X0,0X0,0,0
2,0X0,0X0,0,0
3,0X0,0X0,0,0
4,0X0,0X0,0,0
error: 
File System initialization failed.

Any help/idea would be really appreciated! Thank you!

Get your SD Memory Card formatted using PC and then try.

Tried that also....but it didn't work out :frowning: Same error!!!

If the SD card has come being inserted in an adapter, there is possibly internal bad contact. In this situation, one has go by swapping procedures to sort out which part is wrong.

The SD Card Interfacing involves:

  1. Jumper wires between MEGA and SD Card Driver. ---> Check one by one using sonar DVM.
  2. Contact between Card Driver and the card adapter. ---> Check by swapping the whole/individual assembly
  3. Contact between the SD Micro card and adapter. --->Check by swapping the whole/individual assembly