failure to compile firmware (monoprice maker marlin fw)

Let me start off with I’m very new to Arduino and editing files before compiling. Also not sure if this is the right place to ask this or not since it’s so late (or early for some). Long story short upgraded a Monoprice maker select V2 to a ramps 1.4 controller with a Arduino atmega2560 (clone). The project is not what I’m looking for answers on. I’ve looked on Google for answers but I’m assuming since I’m a novice I’m not finding what I need.

Onto the problem. Failure to compile sketch (Arduino IDE 1.8.10) firmware I’m trying to edit/flash is Marlin 2.0. firmware compiles if I do not edit the configure.h file however I need to edit the configure.h file in order for everything to work properly. followed this guide for setting up the configure.h file. Installing Marlin Firmware on RAMPS 1.4 | RepRap Firmware | Documentations | my home fab Sketch fails to compile, error log below.

marlin error.txt (2.88 KB)

Try this:

  • Delete C:\Users\Infinitemayhem.000\Documents\Arduino\libraries\U8glib
  • Delete C:\Users\Infinitemayhem.000\Documents\Arduino\libraries\arduino_966211
  • Download the version of U8glib that Marlin maintains: https://github.com/MarlinFirmware/U8glib-HAL/archive/bugfix.zip
  • Unzip the downloaded file.
  • (In the Arduino IDE) Sketch > Include Library > Add .ZIP Library
  • Select the src subfolder of the unzipped U8glib-HAL-bugfix folder.
  • Click the “Open” button.
  • Wait for the Arduino IDE to say the library was successfully installed.
  • Try compiling Marlin again.

failed to compile after following your steps. error log below.

marlin error 2.txt (4.24 KB)

I can't reproduce the error when I install the library following my instructions above and compile the stock Marlin 2.0.0. But it might be because you have a custom configuration of Marlin. Please zip up the Marlin you're using and post it here as an attachment.