Failure to connect to DHCP

Hi people

I am currently doing a project in which I need to connect using an ethernet shield to get time. My problem is very strange... I tested the system at home and connected this system to my internet modem and it worked perfectly.... Then last week I connected my system on another router and it was working fine. Then there wasa a power cut in electric domestic supply and I cannot connect again to the DHCP. I tried many different ways but still it is not connecting. I took the arduino with the shield back home and it is still working good at home... Does anyone know if there could be any setting that could be affected from the router due to the power cut? if yes, how could i fix the problem?

You would have to check the router. Rebooting the router may help. After that, the router's dhcp lease list is a good place to start.

What make and model of router is the Arduino having a problem with?

tecnhicolor TG582n i think is the model
By rebooting the router, do you mean to reset back to factory settings? or just switching it off and back on?

Just switch it off and back on.

I rebooted my modem (with which my program was working perfectly)... and now it is not working.... so it must be because of some setting.... do you have any idea why?

Reboot the router, then reboot the Arduino. It may need to make another dhcp request once the router is rebooted.

I have rebooted the arduino as well.... but now the ground is continously blinking and it does not let me even upload the Simple blink LED 13 example on on the board.... i used the second solution of this website

I really do not know what i m really doing right now

Remove the shield, When you start the compile/upload, press the reset button on the Arduino. When the "uploading" message appears, release the reset button.

Insure the shield is connected to the Arduino correctly. Maybe the pins aren't inserted fully into the sockets?