FAQ Neuigkeiten und Probleme ab Arduino IDE 1.0

uk1408: Kennt das jemand und weiß wer was da los sein könnte?

Das liegt sicher nicht an der IDE, sondern an deinem Windows. Versuche doch mal über die Wiederherstellungskonsole auf ei früheres Datum zurück zu setzen.

So, jetzt habe ich ein Backup aufgespielt und geht wieder. Aber woran das lag werde ich jetzt nie erfahren :o

uk1408: So, jetzt habe ich ein Backup aufgespielt und geht wieder. Aber woran das lag werde ich jetzt nie erfahren :o

Warum schreibst du nicht, welches Backup du aufgespielt hast ? Windows ?

Hallo Kann mir jemand sagen was das für ein Board ist? Habe mir ein starter kit uno Arduino bestellt aber es kamm folgendes Board. Danke für eure Bemühungen!!

uno.jpg|800x612

Das ist kein "Arduino Uno TM", wie du schon geahnt hast. Hat einen CH340 für die USB-Kommunikation, was inzwischen der Chinesen-Standard ist. Wenn dein Starterkit gut ist, beschreibt es dir, wie du den reforderlichen Treiber auf deinem PC installierst.

Ansonsten hat es den atmega328 drauf, ist also uno - "kompatibel".

Dann scheinen alle Anschlüsse wahlweise als Buchsen (wie UNO, passend für Shields) und auch als Stifte zur Verfügung zu stehen. Könnte evtl. manchmal praktisch sein.

Der ISP- Anschluss scheint doppelt vorhanden: 6pol. und 10pol. Brauchst du (hoffentlich) erstmal garnicht, wenn dann spart es dir evtl. einen 1Euro Adapter.

Wofür die zusätzlichen Taster gut sind: k.A.

Viel Spass damit! "Ich wünsche dir eine interessante Zeit damit" (soll mal kein Fluch sein, sondern durchaus positiv) ;)

michael_x: Das ist kein "Arduino Uno TM", wie du schon geahnt hast. Hat einen CH340 für die USB-Kommunikation, was inzwischen der Chinesen-Standard ist. Wenn dein Starterkit gut ist, beschreibt es dir, wie du den reforderlichen Treiber auf deinem PC installierst.

Ansonsten hat es den atmega328 drauf, ist also uno - "kompatibel".

Dann scheinen alle Anschlüsse wahlweise als Buchsen (wie UNO, passend für Shields) und auch als Stifte zur Verfügung zu stehen. Könnte evtl. manchmal praktisch sein.

Der ISP- Anschluss scheint doppelt vorhanden: 6pol. und 10pol. Brauchst du (hoffentlich) erstmal garnicht, wenn dann spart es dir evtl. einen 1Euro Adapter.

Wofür die zusätzlichen Taster gut sind: k.A.

Viel Spass damit! "Ich wünsche dir eine interessante Zeit damit" (soll mal kein Fluch sein, sondern durchaus positiv) ;)

Hei das ging aber flott Danke! Für die Info. Das ist das erste mal das ich mich in einem Forum Melde. Leider ist Die Gebrauchs Anweisung Chines-isch wede mich wohl an den Bilder Orientieren. Nochmals Danke!!

Da das Board UNO-kompatibel ist, kannst du alles nutzen, was du über den UNO liest. Naja fast, da er einen anderen USB-Serial-Wandler hat.

Die zusätzlichen Taster sind nochmals als Pin rausgeführt, können somit für erste Versuche mit Tastern nützlich sein.

HotSystems: Warum schreibst du nicht, welches Backup du aufgespielt hast ? Windows ?

Ja, ein Backup meines Betriebssystems WIN10 als es noch gut funktionierte.

uk1408: Ja, ein Backup meines Betriebssystems WIN10 als es noch gut funktionierte.

Ok, danke für die Info. Das wird anderen mit dem selben Problem helfen.

Das Problem "Kompilieren ist plötzlich voll lahm" konnte ich letztens bei mir selber erleben.

Das Problem trat nach einem Board Update auf. In diesem Fall die Standard Boards, UNO usw.. (Die IDE fragt ja immer ganz lieb, ob sie das tun soll...)

Was genau schief läuft, weiß ich nicht... Aber nach löschen des Boards Gedöns in %Appdata%...Arduino15 Lief alles wieder in gewohnter Geschwindigkeit.

Seit ich auf "portable" umgestellt habe, tritt das Problem nicht mehr auf.

Mardetuino: Boardtyp und COM Einstellung im Sketch hinterlegt. Jedes mal dieses lange auswählen nervt.

Klingt erstmal nicht schlecht... Wenn das programmtechnisch machbar wäre... Aber ob man sich auf die COM Einstellungen verlassen kann?

RIN67630: Aber ob man sich auf die COM Einstellungen verlassen kann?

Bei Windows besser nicht

... und unter Linux heißt das Teil anders ;) Denke, der MAC wird hier auch mit anderen Begrifflichkeiten aufwarten können.

Trotzdem ist dem Mac- wie Linux-Nutzer bewusst, was eine COM ist(war).

MfG

Zumindest die Board-Einstellung wäre schon mal eine große Hilfe. Sowie die Baudrate beim Serial Monitor...

Die COM Port Zuordnung war schon damals - bei der Basic Stamp - sehr gut und hat mehr geholfen als geschadet.

Hab' mir die Version 1.8.8 über die alte Arduino gespielt und festgestellt, dass jetzt beim Start immer ein leerer Sketch geladen wird. Früher war das immer der zuletzt bearbeitete Sketch. Gibt's da was zum Einstellen oder handelt es sich um eine unverbesserbare Verbesserung ;-) ?

hajos118: Hab' mir die Version 1.8.8 über die alte Arduino gespielt und festgestellt, dass jetzt beim Start immer ein leerer Sketch geladen wird. Früher war das immer der zuletzt bearbeitete Sketch. Gibt's da was zum Einstellen oder handelt es sich um eine unverbesserbare Verbesserung ;-) ?

It's not a bug, it's a feature... ;)

Geht anscheinend nicht mehr, keine Ahnung ob da dran gearbeitet wird und welche Prio die Funktion hat, aber vielleicht hilft folgende Lösung (geht mit Windows 10, wahrscheinlich auch mit 8 ):

Hefte die IDE an der Taskleiste an und mach nen Rechtsklick auf die Verknüpfung, dann siehst du die zuletzt mit der IDE geöffneten Sketche.

hajos118: Hab' mir die Version 1.8.8 über die alte Arduino gespielt und festgestellt, dass jetzt beim Start immer ein leerer Sketch geladen wird. Früher war das immer der zuletzt bearbeitete Sketch. Gibt's da was zum Einstellen oder handelt es sich um eine unverbesserbare Verbesserung ;-) ?

...beende die IDE mit STRG+Q oder Datei -> beenden.....

Hallo,

ich habe gerade die letzte Version (1.1.10 ?) geladen und installiert. Jetzt geht die IDE wieder mit dem letzten Sketch auf....

Ich habe das mal als portable Installation versucht. Wie ist das mit den Librarays? Irgendwo habe ich gelesen, man solle in dem extrahierten Verzeichnis ein Verzeichnis "portable" anlegen, dort kommen dann in des Verzeichnis "sketchbook" die Sketche und die Librarays rein. Es gibt aber doch auch im "Hauptverzeichnis Arduino" schon ein Libraray-Verzeichnis. Was hat es denn damit auf sich?

Die neueste "stabile" Version ist die 1.8.9.

Wo Du eine 1.1.10 ausgegraben hast, weiß ich nicht.

Gruß Tommy

...hier.. bei den HOURLY BUILDS.

Kannst du mir trotzdem was zu den Librarays sagen? Und wie gehst du dann bei einem Update vor? Einfach die neue Version auspacken und nur den portabel-Ordner komplett von alten in den neuen Ordner kopieren?