FAQ Neuigkeiten und Probleme ab Arduino IDE 1.0

Mardetuino: Boardtyp und COM Einstellung im Sketch hinterlegt. Jedes mal dieses lange auswählen nervt.

Klingt erstmal nicht schlecht... Wenn das programmtechnisch machbar wäre... Aber ob man sich auf die COM Einstellungen verlassen kann?

RIN67630: Aber ob man sich auf die COM Einstellungen verlassen kann?

Bei Windows besser nicht

... und unter Linux heißt das Teil anders ;) Denke, der MAC wird hier auch mit anderen Begrifflichkeiten aufwarten können.

Trotzdem ist dem Mac- wie Linux-Nutzer bewusst, was eine COM ist(war).

MfG

Zumindest die Board-Einstellung wäre schon mal eine große Hilfe. Sowie die Baudrate beim Serial Monitor...

Die COM Port Zuordnung war schon damals - bei der Basic Stamp - sehr gut und hat mehr geholfen als geschadet.

Hab' mir die Version 1.8.8 über die alte Arduino gespielt und festgestellt, dass jetzt beim Start immer ein leerer Sketch geladen wird. Früher war das immer der zuletzt bearbeitete Sketch. Gibt's da was zum Einstellen oder handelt es sich um eine unverbesserbare Verbesserung ;-) ?

hajos118: Hab' mir die Version 1.8.8 über die alte Arduino gespielt und festgestellt, dass jetzt beim Start immer ein leerer Sketch geladen wird. Früher war das immer der zuletzt bearbeitete Sketch. Gibt's da was zum Einstellen oder handelt es sich um eine unverbesserbare Verbesserung ;-) ?

It's not a bug, it's a feature... ;)

Geht anscheinend nicht mehr, keine Ahnung ob da dran gearbeitet wird und welche Prio die Funktion hat, aber vielleicht hilft folgende Lösung (geht mit Windows 10, wahrscheinlich auch mit 8 ):

Hefte die IDE an der Taskleiste an und mach nen Rechtsklick auf die Verknüpfung, dann siehst du die zuletzt mit der IDE geöffneten Sketche.

hajos118: Hab' mir die Version 1.8.8 über die alte Arduino gespielt und festgestellt, dass jetzt beim Start immer ein leerer Sketch geladen wird. Früher war das immer der zuletzt bearbeitete Sketch. Gibt's da was zum Einstellen oder handelt es sich um eine unverbesserbare Verbesserung ;-) ?

...beende die IDE mit STRG+Q oder Datei -> beenden.....

Hallo,

ich habe gerade die letzte Version (1.1.10 ?) geladen und installiert. Jetzt geht die IDE wieder mit dem letzten Sketch auf....

Ich habe das mal als portable Installation versucht. Wie ist das mit den Librarays? Irgendwo habe ich gelesen, man solle in dem extrahierten Verzeichnis ein Verzeichnis "portable" anlegen, dort kommen dann in des Verzeichnis "sketchbook" die Sketche und die Librarays rein. Es gibt aber doch auch im "Hauptverzeichnis Arduino" schon ein Libraray-Verzeichnis. Was hat es denn damit auf sich?

Die neueste "stabile" Version ist die 1.8.9.

Wo Du eine 1.1.10 ausgegraben hast, weiß ich nicht.

Gruß Tommy

...hier.. bei den HOURLY BUILDS.

Kannst du mir trotzdem was zu den Librarays sagen? Und wie gehst du dann bei einem Update vor? Einfach die neue Version auspacken und nur den portabel-Ordner komplett von alten in den neuen Ordner kopieren?

Das könnte mal eine 1.8.10 werden.

Ich lege für neue Versionen der IDE jeweils ein neues portables Verzeichnis an, dass die Versiponsnummer und manchmal auch die ESP8266-Versionsnummer enthält.

Die Libs, die Du selbst installierst gehören nach /libraries.

@Uwe: Ich glaube die Diskussion könnte aus diesem Hauptthread abgespalten werden. Ich weiß aber nicht wo.

Gruß Tommy

Hallo Community,
Habe vor ein paar Tagen ein seltsames Verhalten der IDE 1.8.9 unter Win10 entdeckt. Ist die Installierte, also nicht mobile Version.

Und zwar folgendes: ich war am austesten eines touchsensors, der ne 70cm lange Sensorfläche hat. musste deshalb mit den Werten, elektronisch sowie auch programmtechnisch spielen, da die mpfindlichkeit extrem hoch , aber auch recht unstabil war.

Hab dabei immer wieder änderungen am sketch vorgenommen, auch mal das ganze übern haufen geworfen und wieder neu begonnen.

Nun ergab es sich plötzlich, dass der Nano trotz hochladen des Sketches mit neuen Werten immer wieder mit einer älteren version des sketches zu arbeiten schien.

Hab dann den Sketch gespeichert , IDE geschlossen IDE neu gestartet, sketch frisch geladen, - war auch
in der gewünschten Form im Editor zu sehen, kompiliert und hochgeladen, was auch fehlerfrei geklappt hat.
Und dann, spielte der Nano wieder die alte Version des Programms ab - hä???

Ich wollte schon den rechner neu starten, dann sah ich in der taskleiste, dass noch ne Instanz der IDE offen war, hab das Fenster hochgeholt und sehe - die Alte Version meines Sketches!

Aber warum wird denn nicht die Version hochgeladen, aus der Instanz der IDE mit der ich grad arbeite und in der ich auf Kompilieren und Hochladen drücke?

Das Finde ich etwas verwirrend.

Hat da einer von Euch ne Idee dazu?

LG Stefan

Wenn ich mehrere Projekte gleichzeitig bearbeite, nehme ich immer verschiedene Versionen der IDE, nicht 2 Instanzen derselben Version.

Guter Workaround! Jedoch bleibt die Frage: Warum lädt die IDE den Code aus einer anderen Instanz hoch , anstatt aus der Instanz, mit der ich grad aktiv arbeite und in der ich den Kompilieren/Hochladen Button anklicke?

LG Stefan

Wenn ich die IDE öffne, lädt die IDE meistens die letzten Sketches, die beim runterfahren geladen war. Zumindest meistens

Ich hatte ja in der Instanz den sketch , den ich hochladen wollte, hab ja daran gearbeitet. Und in einer weiteren Instanz war der selbe sketch in ner vorherigen version. Ich frage mich , warum wird der compillierte code aus einer vorherigen version hochgeladen und nicht derjenige , der gerade frisch erzeugt wurde, oder hätte werden sollen? Meine IDE ist übrigens so eingestellt, dass der sketch vor dem Überprüfen und Hochladen Gespeichert wird.

LG Stefan

Eine nahezu identische Erfahrung hatte ich auch schon. Bis ich dann irgendwann merkte, dass ich die Versionen verwechselte, also das Problem vor dem Monitor saß.

Wenn du allerdings win10 drauf hast, würde mich gar nichts mehr wundern. :smiling_imp:

ok dann schaue ich mal, wie es sich auf meinem älteren Laptop , mit win7 verhällt.

LG Stefan

Hallo Leute!

Ich hab leider, seit längerem, nicht mehr die Zeit gehabt meinem Arduino Hobby nachzugehen. Nachdem ich also mehrere Monate nichts mehr gemacht hab, hab ich mir die neueste Arduino IDE (v1.8.9) heruntergeladen und installiert. Davor hatte ich die v.1.8.5. (Windows 10)

Beim starten der IDE bzw. eigentlich nur wenn ich den "Boardmanager" öffne werde ich folgendes gefragt:

Es konnte keine boards.txt in D:\...\Arduino\hardware\Sanguino-master\bootloaders gefunden werden. Ist sie noch von einer Version vor Arduino 1.5?
Es konnte keine boards.txt in D:\...\Arduino\hardware\Sanguino-master\variants gefunden werden. Ist sie noch von einer Version vor Arduino 1.5?
Es konnte keine boards.txt in D:\...\Arduino\hardware\Sanguino-master\bootloaders gefunden werden. Ist sie noch von einer Version vor Arduino 1.5?
Es konnte keine boards.txt in D:\...\Arduino\hardware\Sanguino-master\variants gefunden werden. Ist sie noch von einer Version vor Arduino 1.5?

Die Antwort ist "Ja" aber was bedeutet das bzw. was soll ich machen?

Danke für jede Hilfe!

Grüße, Donny

dony: Hallo Leute!

Ich hab leider, seit längerem, nicht mehr die Zeit gehabt meinem Arduino Hobby nachzugehen. Nachdem ich also mehrere Monate nichts mehr gemacht hab, hab ich mir die neueste Arduino IDE (v1.8.9) heruntergeladen und installiert. Davor hatte ich die v.1.8.5. (Windows 10)

Beim starten der IDE bzw. eigentlich nur wenn ich den "Boardmanager" öffne werde ich folgendes gefragt:

Es konnte keine boards.txt in D:\...\Arduino\hardware\Sanguino-master\bootloaders gefunden werden. Ist sie noch von einer Version vor Arduino 1.5?
Es konnte keine boards.txt in D:\...\Arduino\hardware\Sanguino-master\variants gefunden werden. Ist sie noch von einer Version vor Arduino 1.5?
Es konnte keine boards.txt in D:\...\Arduino\hardware\Sanguino-master\bootloaders gefunden werden. Ist sie noch von einer Version vor Arduino 1.5?
Es konnte keine boards.txt in D:\...\Arduino\hardware\Sanguino-master\variants gefunden werden. Ist sie noch von einer Version vor Arduino 1.5?

Die Antwort ist "Ja" aber was bedeutet das bzw. was soll ich machen?

Danke für jede Hilfe!

Grüße, Donny

Das ist kein Thema für diesen Thread!!!!! Der hat einen anderen Sinn.