Fast flashing pin13 / upload fails

After having tried a few programs (the latest is http://www.arduino.cc/cgi-bin/yabb2/YaBB.pl?num=1216153005 ) my arduino decimilla no longer responds.

When powered the led on pin13 flashes fast 100msec maybe. When I send something on the serial port, the rx port flashes. When I try to upload from the Arduino software the rx led flashes shortly, but pin13 just goes on.

Some times the led stops and when I try to flash a program it restarts.

It has been working fine on this computer all day (I got it today), and my last program didnt use pin13, so no idea what would go wrong.

The last many programs used same hardware setup so no changes there.

I have tried setting the DTR close flag in control panel, no change.

I have tried powering it from usb and a wallwart, same responce. The computer is WinXP Pro.

I will try from another computer tomorro, also an WinXP pro.

What a bummer, it started out so fine and less than 24times later its dead in the water :(

Same problem on other computer :'(

Binary sketch size: 1096 bytes (of a 14336 byte maximum)


avrdude: stk500_getsync(): not in sync: resp=0x00
avrdude: stk500_disable(): protocol error, expect=0x14, resp=0x51

After a few hours of searching the forum, I found the solution :) Plug in usb cable, start arduino program, unplug usb cable, press upload, plug in cable fast (or serial port error comes) and it works :D

Found it here http://www.arduino.cc/cgi-bin/yabb2/YaBB.pl?num=1214681992

Instead of this procedure, did you try pressing reset right after clicking upload? And did you try pressing reset after "X" seconds you clicked upload?

X=5, 10, 20, etc. seconds.

yes, i tried at many intervals, everytime the led would just go back to blinking fast.

when powering it on, it flashes slow at pin13 a few times then fast again.
but if you start upload just before plugging it in, the download starts before the fast flash process.