Fatal exception (0): on ESP8266 with arduino Due

I am working with ESP8266 on arduino due, i shorted the serial and using serial0 for communicating with the module, it was working fine for few days suddenly it showed up this error at a very different baud rate-74880

ets Jan 8 2013,rst cause:2, boot mode:(3,7)

load 0x40100000, len 612, room 16
tail 4
chksum 0x12
⸮⸮&⸮V⸮⸮⸮bb⸮⸮⸮788, room 4
tail 0
chksum 0x50
load 0x3ffe8314, len 264, room 8
tail 0
chksum 0x4a
csum 0x4a

2nd boot version : 1.1
SP⸮⸮j!⸮5
SPI Mode : QIO
SPI Flash Size : 4Mbit
jump to run user1

Fatal exception (0):
epc1=0x40211558, epc2=0x00000000, epc3=0x00000000, excvaddr=0x00000000, depc=0x00000000
Fatal exception (0):
epc1=0x40211558, epc2=0x00000000, epc3=0x00000000, excvaddr=0x00000000, depc=0x00000000
Fatal exception (0):
epc1=0x40211558, epc2=0x00000000, epc3=0x00000000, excvaddr=0x00000000, depc=0x00000000
Fatal exception (0):

the first part until "jump to run user1" is always there.
what application should run in esp8266? AT firmware? or your sketch?

how do you power the esp8266?

Shravan_Anand_K:
I am working with ESP8266 on arduino due....

What does that mean ?

Shravan_Anand_K:
i shorted the serial and using serial0 for communicating with the module

What does that mean ?

i connected the tx of wifi module to tx0 of arduino and rx to rxo, and reset pin of arduino due to GND, so that i can directly communicate with wifi module using COM port, it was working fine at 9600 baud i was able to send AT commands on serial monitor buT suddenly it crashed and sending the above exception at a different baud rate.
i connected VCC to 3.3v, CH_PD to 53 pin of arduino DUE

Shravan_Anand_K:
i connected the tx of wifi module to tx0 of arduino and rx to rxo, and reset pin of arduino due to GND, so that i can directly communicate with wifi module using COM port, it was working fine at 9600 baud i was able to send AT commands on serial monitor buT suddenly it crashed and sending the above exception at a different baud rate.
i connected VCC to 3.3v, CH_PD to 53 pin of arduino DUE

once you joined an AP it uses WiFi and starts the connection at boot. but the powering fails to provide enough current and the esp8226 crashes