Fehler beim Hochladen: Fehlender Konfigurationsparameter 'upload.tool'

Hallo zusammen

Nachdem mir die Arduino IDE neulich beim Starten den Finger zeigte und meinte, ich müsste die alte Java Runtimedingsbums Nr. 6 installieren, um dieses Programm weiterhin zu benützen, habe ich halt die neuste Version (1.5.8) runtergeladen und installiert.
Für den UNO funktioniert diese ohne Probleme, allerdings bereitet es mir beim Programmieren eines anderen Projektes Probleme. Da dieses um einen ATMEGA324P aufgebaut ist, musste ich die boards.txt etwas verändern und die Dateien pins_arduino.c und pins_arduino.h ergänzen. Im alten Programm konnte ich ihn danach problemlos programmieren. Mit der neuen Version wird mir allerdings nach dem Kompilieren immer die folgende Fehlermeldung angezeigt:

Fehler beim Hochladen: Fehlender Konfigurationsparameter 'upload.tool'

Ich habe keine Ahnung, wonach ich suchen soll. Das Problem besteht sowohl, wenn ich über den usbTiny programmieren will, als auch, wenn ich den Uno als ISP Programmer einsetze.
Was die Fehlersuche möglicherweise ein wenig erschwert, ist, dass ich keinen Testsketch aufzuspielen versuchen möchte. Denn, wenn das gelingen würde, könnte ich das Gerät nichtmal mehr mit dem Code nutzen, den ich im Moment noch drauf habe.

Weiss jemand, wo ich ansetzen soll? Oder noch besser, wie man das Problem lösen könnte :grinning: ?
Die drei veränderten Dateien hab ich schon durchgekuckt und auch wenn ich nicht viel davon verstehe, kommt mir nichts davon verdächtig vor... :confused:

Hitsuji:
Fehler beim Hochladen: Fehlender Konfigurationsparameter 'upload.tool'

Ich habe keine Ahnung, wonach ich suchen soll.

Schau Dir mal die boards.txt Einträge an und vergleiche die neuen Konfigurationsparameter in der 1.5.x-IDE mit den alten boards.txt Einträgen einer alten 1.0.x-IDE!

Ich schätze mal, Du versuchst "alte" boards.txt Einträge einer neuen 1.5.x Version unterzuschieben und hast dabei vergessen, die neuen Parameter, die in der Konfiguration gesetzt sein müssen, sinnvoll zu setzen.

Ja natürlich hab ich das getan. Alles copy-paste… und dabei hab ich noch behauptet, ich hätte die veränderten Dateien angeschaut… die boards.txt natürlich nicht :cold_sweat:

Ich vergleiche mal den alten und den neuen Eintrag für den UNO und versuche die Veränderungen nachzuvollziehen. Falls ichs nicht hinkriege melde ich mich dann wieder. Vielen Dank für den Hinweis!

Installier die Arduino 1.6 blank ohne Reste der alten! Nicht nur copy und paste drüber schieben.

... und es programmiert wieder! Danke jurs!!