Fehler beom Kompilieren mit Attiny 45

Gesundes Neues Jahr zusammen,

ich kämpfe mich schon seit Tagen damit rum, ein kleines Sketch für meine Modellbahn auf den Attiny 45 zu schieben.
Das Programm läuft auf dem Arduino Mega 2560 und soll nun auf den Attiny verschoben werden.

Mein Problem liegt darin, dass sobald ich den Code mit der auswahl des Boardes auf dem Attiny 45 (egal ob 1 oder 8 MHz) folgender Error kommt:

Arduino: 1.6.7 (Linux), Board: "ATtiny45 (internal 1 MHz clock)"

/home/modellbahner/Dokumente/arduino/arduino-1.6.7/arduino-builder -dump-prefs -logger=machine -hardware "/home/modellbahner/Dokumente/arduino/arduino-1.6.7/hardware" -tools "/home/modellbahner/Dokumente/arduino/arduino-1.6.7/tools-builder" -tools "/home/modellbahner/Dokumente/arduino/arduino-1.6.7/hardware/tools/avr" -built-in-libraries "/home/modellbahner/Dokumente/arduino/arduino-1.6.7/libraries" -libraries "/home/modellbahner/Arduino/libraries" -fqbn=attiny-master:attiny:attiny45 -vid-pid=0X2341_0X0042 -ide-version=10607 -build-path "/tmp/build743f7757ac6ff632e702c3e109bd2aad.tmp" -warnings=none -prefs=build.warn_data_percentage=75 -verbose "/tmp/arduino_743f7757ac6ff632e702c3e109bd2aad/Blink.ino"
/home/modellbahner/Dokumente/arduino/arduino-1.6.7/arduino-builder -compile -logger=machine -hardware "/home/modellbahner/Dokumente/arduino/arduino-1.6.7/hardware" -tools "/home/modellbahner/Dokumente/arduino/arduino-1.6.7/tools-builder" -tools "/home/modellbahner/Dokumente/arduino/arduino-1.6.7/hardware/tools/avr" -built-in-libraries "/home/modellbahner/Dokumente/arduino/arduino-1.6.7/libraries" -libraries "/home/modellbahner/Arduino/libraries" -fqbn=attiny-master:attiny:attiny45 -vid-pid=0X2341_0X0042 -ide-version=10607 -build-path "/tmp/build743f7757ac6ff632e702c3e109bd2aad.tmp" -warnings=none -prefs=build.warn_data_percentage=75 -verbose "/tmp/arduino_743f7757ac6ff632e702c3e109bd2aad/Blink.ino"
Das Board attiny-master:attiny:attiny45-8 definiert keine "build.board"-Einstellung. Sie wurde automatisch auf ATTINY_ATTINY45-8 festgelegt.
Das Board attiny-master:attiny:attiny85-20 definiert keine "build.board"-Einstellung. Sie wurde automatisch auf ATTINY_ATTINY85-20 festgelegt.
Das Board attiny-master:attiny:attiny45-20 definiert keine "build.board"-Einstellung. Sie wurde automatisch auf ATTINY_ATTINY45-20 festgelegt.
Das Board attiny-master:attiny:attiny85-8 definiert keine "build.board"-Einstellung. Sie wurde automatisch auf ATTINY_ATTINY85-8 festgelegt.
Das Board attiny-master:attiny:attiny84 definiert keine "build.board"-Einstellung. Sie wurde automatisch auf ATTINY_ATTINY84 festgelegt.
Das Board attiny-master:attiny:attiny44 definiert keine "build.board"-Einstellung. Sie wurde automatisch auf ATTINY_ATTINY44 festgelegt.
Das Board attiny-master:attiny:attiny85 definiert keine "build.board"-Einstellung. Sie wurde automatisch auf ATTINY_ATTINY85 festgelegt.
Das Board attiny-master:attiny:attiny84-20 definiert keine "build.board"-Einstellung. Sie wurde automatisch auf ATTINY_ATTINY84-20 festgelegt.
Das Board attiny-master:attiny:attiny44-20 definiert keine "build.board"-Einstellung. Sie wurde automatisch auf ATTINY_ATTINY44-20 festgelegt.
Das Board attiny-master:attiny:attiny44-8 definiert keine "build.board"-Einstellung. Sie wurde automatisch auf ATTINY_ATTINY44-8 festgelegt.
Das Board attiny-master:attiny:attiny84-8 definiert keine "build.board"-Einstellung. Sie wurde automatisch auf ATTINY_ATTINY84-8 festgelegt.
Das Board attiny-master:attiny:attiny45 definiert keine "build.board"-Einstellung. Sie wurde automatisch auf ATTINY_ATTINY45 festgelegt.
""   -w -x c++ -E -CC -DF_CPU=1000000L -DARDUINO=10607 -DARDUINO_ATTINY_ATTINY45 -DARDUINO_ARCH_ATTINY         "-I/home/modellbahner/Dokumente/arduino/arduino-1.6.7/hardware/attiny-master/attiny/cores/arduino" "-I/home/modellbahner/Dokumente/arduino/arduino-1.6.7/hardware/attiny-master/attiny/variants/tiny8" "/tmp/build743f7757ac6ff632e702c3e109bd2aad.tmp/sketch/Blink.ino.cpp" -o "/dev/null"
""   -w -x c++ -E -CC -DF_CPU=1000000L -DARDUINO=10607 -DARDUINO_ATTINY_ATTINY45 -DARDUINO_ARCH_ATTINY         "-I/home/modellbahner/Dokumente/arduino/arduino-1.6.7/hardware/attiny-master/attiny/cores/arduino" "-I/home/modellbahner/Dokumente/arduino/arduino-1.6.7/hardware/attiny-master/attiny/variants/tiny8" "/tmp/build743f7757ac6ff632e702c3e109bd2aad.tmp/sketch/Blink.ino.cpp" -o "/dev/null"
""   -w -x c++ -E -CC -DF_CPU=1000000L -DARDUINO=10607 -DARDUINO_ATTINY_ATTINY45 -DARDUINO_ARCH_ATTINY         "-I/home/modellbahner/Dokumente/arduino/arduino-1.6.7/hardware/attiny-master/attiny/cores/arduino" "-I/home/modellbahner/Dokumente/arduino/arduino-1.6.7/hardware/attiny-master/attiny/variants/tiny8" "/tmp/build743f7757ac6ff632e702c3e109bd2aad.tmp/sketch/Blink.ino.cpp" -o "/tmp/build743f7757ac6ff632e702c3e109bd2aad.tmp/preproc/ctags_target_for_gcc_minus_e.cpp"
exec: "-w": executable file not found in $PATH
Fehler beim Kompilieren.

Ich habe die neuste Version vom Attiny-Master ( Github), neueste IDE und es geht einfach nicht.

Hab das ganze auch mal unter Windows ausprobiert. Auch nix.

Die obrige Fehlermeldung kam übringens beim kompilieren von dem Blink Programm zustande.

Als Programmer habe ich den Arduino Mega 2560 als ISP, der läuft (siehe LED Pin 9).

Ich hoffe hier kann mir jemand helfen!
Grüße und Danke

Hallo,

ich habe gerade einen Test gemacht:
Neueste IDE 1.6.7 unter Linux
Attiny by David A. Mellis Version 1.0.1 mit dem Boardmanager geladen.

Attiny45 8 MHz compiliert Blink ohne Fehler

Versuch es doch auch mal die Attiny Libs mit dem Boardmanager zu installieren.
Diesen Eintrag dazu in die Voreinstellungen unter zusätzliche Boardverwalter URLs aufnehmen.
https://raw.githubusercontent.com/damellis/attiny/ide-1.6.x-boards-manager/package_damellis_attiny_index.json

Viel Glück
Reinhard

Hallo ernie-berni,

danke für den Tipp! Jetzt gehts schonmal nen Schritt weiter, bis während dem Upload der Arduino "abstürtzt".

Die LED an Pin 9 geht aus und es kommt folgende Fehlermeldung:

Arduino: 1.6.7 (Linux), Board: "ATtiny, ATtiny45, 1 MHz (internal)"

Der Sketch verwendet 994 Bytes (24%) des Programmspeicherplatzes. Das Maximum sind 4.096 Bytes.
Globale Variablen verwenden 15 Bytes des dynamischen Speichers.
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 1 of 10: not in sync: resp=0x00
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 2 of 10: not in sync: resp=0x00
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 3 of 10: not in sync: resp=0x00
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 4 of 10: not in sync: resp=0x00
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 5 of 10: not in sync: resp=0x00
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 6 of 10: not in sync: resp=0x00
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 7 of 10: not in sync: resp=0x00
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 8 of 10: not in sync: resp=0x00
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 9 of 10: not in sync: resp=0x00
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 10 of 10: not in sync: resp=0x00
Problem beim Hochladen auf das Board. Hilfestellung dazu unter http://www.arduino.cc/en/Guide/Troubleshooting#upload.

  Dieser Report hätte mehr Informationen mit
  "Ausführliche Ausgabe während der Kompilierung"
  aktiviert in Datei > Einstellungen.

Nachdem der ausführliche Bericht zu lang ist die Kurzfassung xD

Danke und Grüßle

was macht die Led an Pin 9?

Ich mache das mit einem UNO, da ist Pin 9 frei, benutzt sind die Pins 10 bis 13, Reset an Kondensator, 5V und GND als Spannungsversorgung.

EDIT: Auch 7, 8 und 9 sind belegt, s. u.!

SachsenBahner nutzt einen Mega 2560 und da sind es die Pin's 50 -53, deshalb verstehe ich Pin 9 nicht

Hallo,

die LED an Pin 9 zeigt durch auf und abblenden an, dass der Programmer betriebsbereit ist.

Siehe hier:

// Put an LED (with resistor) on the following pins:
// 9: Heartbeat   - shows the programmer is running
// 8: Error       - Lights up if something goes wrong (use red if that makes sense)
// 7: Programming - In communication with the slave

Gruß

Hallo,

Problem gefunden:
Das Kabel zum Kondensator hatte einen Schaden.
Jetzt kommt nur noch Folgender Fehler xD

avrdude: Yikes!  Invalid device signature.
         Double check connections and try again, or use -F to override
         this check.

Was geht da schonwieder schief?

Grüßle

// Put an LED (with resistor) on the following pins:
// 9: Heartbeat - shows the programmer is running
// 8: Error - Lights up if something goes wrong (use red if that makes sense)
// 7: Programming - In communication with the slave

woher stammt dieser Text?

Wie hast du deinen Attiny mit dem Mega verdahtet? Hast du den Kondensator am Reset?

Hallo,

Verdrahtung siehe:

Kondensator richtig dran.

Der Text stammt aus dem Beispiel "ArduinoISP" in der Arduino IDE.

Grüßle

SachsenBahner:
Der Text stammt aus dem Beispiel "ArduinoISP" in der Arduino IDE.

Ich bitte um Nachsicht, habe ich bisher übersehen!

avrdude: Yikes! Invalid device signature.

Du mußt ATtiny45 in der IDE unter "Werkzeuge/Platine" einstellen. War zumindest bisher so (ich verwende IDE 1.6.5) :smiley:

Hallo,

ja das habe ich, Board ATtiny45, 1MHz Clock, Arduino as ISP als Programmer.

Grüßle

Hast Du vorher den Sketch ArduinoISP auf den Mega geladen, ohne Kondensator?

Ja, der Sketch mit dem ISP ist ohne Kondensator auf den Mega geladen worden.

Ich habe meinen Mega2560 hervorgeholt und den Blink-Sketch auf den ATtiny45 (1 MHz) übertragen, jetzt auch mit Herzschlag (IDE 1.6.5). Unter “Datei/Voreinstellungen” habe ich “Ausführliche Ausgabe während Hochladen” gewählt. Die Device signature habe ich farblich hervorgehoben:

Build-Optionen wurden verändert, alles wird neu gebaut

Der Sketch verwendet 748 Bytes (18%) des Programmspeicherplatzes. Das Maximum sind 4.096 Bytes.
Globale Variablen verwenden 11 Bytes (4%) des dynamischen Speichers, 245 Bytes für lokale Variablen verbleiben. Das Maximum sind 256 Bytes.
C:\Program Files (x86)\Arduino165\hardware\tools\avr/bin/avrdude -CC:\Program Files (x86)\Arduino165\hardware\tools\avr/etc/avrdude.conf -v -pattiny45 -cstk500v1 -PCOM4 -b19200 -Uflash:w:C:\Users\Andreas\AppData\Local\Temp\build1999302360013019762.tmp/Blink.cpp.hex:i

avrdude: Version 6.0.1, compiled on Apr 15 2015 at 19:59:58
        Copyright (c) 2000-2005 Brian Dean, http://www.bdmicro.com/
        Copyright (c) 2007-2009 Joerg Wunsch

System wide configuration file is “C:\Program Files (x86)\Arduino165\hardware\tools\avr/etc/avrdude.conf”

Using Port                    : COM4
        Using Programmer              : stk500v1
        Overriding Baud Rate          : 19200
        AVR Part                      : ATtiny45
        Chip Erase delay              : 4500 us
        PAGEL                         : P00
        BS2                           : P00
        RESET disposition             : possible i/o
        RETRY pulse                   : SCK
        serial program mode           : yes
        parallel program mode         : yes
        Timeout                       : 200
        StabDelay                     : 100
        CmdexeDelay                   : 25
        SyncLoops                     : 32
        ByteDelay                     : 0
        PollIndex                     : 3
        PollValue                     : 0x53
        Memory Detail                 :

Block Poll               Page                       Polled
          Memory Type Mode Delay Size  Indx Paged  Size   Size #Pages MinW  MaxW   ReadBack
          ----------- ---- ----- ----- ---- ------ ------ ---- ------ ----- ----- ---------
          eeprom        65     6     4    0 no        256    4      0  4000  4500 0xff 0xff
          flash         65     6    32    0 yes      4096   64     64  4500  4500 0xff 0xff
          signature      0     0     0    0 no          3    0      0     0     0 0x00 0x00
          lock           0     0     0    0 no          1    0      0  9000  9000 0x00 0x00
          lfuse          0     0     0    0 no          1    0      0  9000  9000 0x00 0x00
          hfuse          0     0     0    0 no          1    0      0  9000  9000 0x00 0x00
          efuse          0     0     0    0 no          1    0      0  9000  9000 0x00 0x00
          calibration    0     0     0    0 no          2    0      0     0     0 0x00 0x00

Programmer Type : STK500
        Description     : Atmel STK500 Version 1.x firmware
        Hardware Version: 2
        Firmware Version: 1.18
        Topcard         : Unknown
        Vtarget         : 0.0 V
        Varef           : 0.0 V
        Oscillator      : Off
        SCK period      : 0.1 us

avrdude: AVR device initialized and ready to accept instructions

Reading | ################################################## | 100% 0.05s

avrdude: Device signature = 0x1e9206
avrdude: NOTE: “flash” memory has been specified, an erase cycle will be performed
        To disable this feature, specify the -D option.
avrdude: erasing chip
avrdude: reading input file “C:\Users\Andreas\AppData\Local\Temp\build1999302360013019762.tmp/Blink.cpp.hex”
avrdude: writing flash (748 bytes):

Writing | ################################################## | 100% 1.28s

avrdude: 748 bytes of flash written
avrdude: verifying flash memory against C:\Users\Andreas\AppData\Local\Temp\build1999302360013019762.tmp/Blink.cpp.hex:
avrdude: load data flash data from input file C:\Users\Andreas\AppData\Local\Temp\build1999302360013019762.tmp/Blink.cpp.hex:
avrdude: input file C:\Users\Andreas\AppData\Local\Temp\build1999302360013019762.tmp/Blink.cpp.hex contains 748 bytes
avrdude: reading on-chip flash data:

Reading | ################################################## | 100% 0.80s

avrdude: verifying …
avrdude: 748 bytes of flash verified

avrdude done.  Thank you.

Möglicherweise läßt sich an den Unterschieden etwas erkennen.

SachsenBahner:
Hallo,

ja das habe ich, Board ATtiny45, 1MHz Clock, Arduino as ISP als Programmer.

Grüßle

Hi,

hast du auch mit “Bootloader brennen” die Fuses des AtTiny setzen lassen?

Ulli.