Fehlermeldung beim Hochladen auf MicroView

Mich nervt plötzlich folgende Fehlermeldung beim Upload:

"avrdude: no programmer has been specified on the command line or the config file
Specify a programmer using the -c option and try again"

Hab nicht an der Programmer-Einstellung rumgefummelt. AVRISP mkll - Vormittag ging noch alles.

Was will der von mir? :o

Hast Du mal die ausführlichen Meldungen aktiviert? Da sehe ich für den UNO:

C:\Program Files (x86)\Arduino165\hardware\tools\avr/bin/avrdude -CC:\Program Files (x86)\Arduino165\hardware\tools\avr/etc/avrdude.conf -v -patmega328p -carduino -PCOM3 -b115200 -D

oder den Mega2560:

C:\Program Files (x86)\Arduino165\hardware\tools\avr/bin/avrdude -CC:\Program Files (x86)\Arduino165\hardware\tools\avr/etc/avrdude.conf -v -patmega2560 -cwiring -PCOM13 -b115200 -D

oder den ATtiny85:

C:\Program Files (x86)\Arduino165\hardware\tools\avr/bin/avrdude -CC:\Program Files (x86)\Arduino165\hardware\tools\avr/etc/avrdude.conf -v -pattiny85 -cstk500v1 -PCOM3 -b19200

Was steht da bei Dir?

hi,

wieso AVRISP MkII ? wird das ding nicht über USB programmiert ?

machst Du in der IDE "upload" oder "upload mit programmer"

gruß stefan

@agmue:
Wie stelle ich "ausführlichen Meldungen" ein?

@eisebaer:
Bei beiden gleiche Meldung: "upload" oder "upload mit programmer"

Der Uno lässt sich auch nicht mehr beladen. Gleiche Meldung.

Hatte zwischendurch mal "update"-Meldung bekommen und diese auch durchgeführt - evtl. war das ein Käse-Update und hat mir die IDE gecrash`t - grrrrr

stoni99:
Wie stelle ich "ausführlichen Meldungen" ein?

IDE 1.6.5: Datei / Voreinstellungen / Ausführliche Ausgabe während:

Ahhhh!

Hab was gefunden.

Hier steht was von update inkompatibel.

Ich nutze die IDE 1.6.7 um auch den genuino 101 nutzen zu können.

Ich musste im Boardverwalter die Arduino AVR Boards Version auf 1.6.8 zurücksetzen. Jetzt funtz die Übertragung wieder.
Ein paar Warnungen gibt es aber:

WARNUNG: Kategorie '' in der Bibliothek EEPROM ist ungültig und wird auf 'Uncategorized' festgelegt
WARNUNG: Kategorie '' in der Bibliothek SPI ist ungültig und wird auf 'Uncategorized' festgelegt
WARNUNG: Kategorie '' in der Bibliothek SoftwareSerial ist ungültig und wird auf 'Uncategorized' festgelegt
WARNUNG: Kategorie '' in der Bibliothek Wire ist ungültig und wird auf 'Uncategorized' festgelegt
Warnung: platform.txt aus dem Kern 'Arduino AVR Boards' enthält veraltete recipe.ar.pattern="{compiler.path}{compiler.ar.cmd}" {compiler.ar.flags} {compiler.ar.extra_flags} "{build.path}/{archive_file}" "{object_file}" und wurde automatisch zu recipe.ar.pattern="{compiler.path}{compiler.ar.cmd}" {compiler.ar.flags} {compiler.ar.extra_flags} "{archive_file_path}" "{object_file}" konvertiert. Erwägen Sie eine Aktualisierung dieses Kerns.

Die Arduino AVR Boards Version 1.6.11 funktioniert auch - dann auch ohne Warnmeldungen.

Nur die neuste 1.6.12 blockiert bei meiner IDE 1.6.7 die Übertragung.