Fehlermeldung - ich verzweifle

Hallo zusammen,

ich schreibe derzeit ein ausführliches Programm auf meinen Arduino Uno. Leider bekomme ich nach dem Einfügen von LCD Befehlen folgende Fehlermeldung (die LCD Befehle tauchen an verschiedenen Stellen bereits im Quellcode auf - ich habe sie nur nochmal kopiert und die Fehlermeldung erscheint). Der Quellcode umfasst aktuell etwa 750 Zeilen.

Für eure Hilfe jetzt schon vielen Dank!

Arduino: 1.8.8 (Windows Store 1.8.19.0) (Windows 10), Board: "Arduino/Genuino Uno"

In file included from C:\Users\simon\Documents\Arduino\libraries\NewliquidCrystal/LiquidCrystal_I2C.h:35:0,

                from C:\Users\simon\Documents\Arduino\LEDTaster\test_3\test_3.ino:3:

C:\Users\simon\Documents\Arduino\libraries\NewliquidCrystal/LCD.h:89:40: warning: unused parameter 'uSec' [-Wunused-parameter]

inline static void waitUsec ( uint16_t uSec )

                                       ^

C:\Users\simon\Documents\Arduino\libraries\NewliquidCrystal/LCD.h:486:43: warning: unused parameter 'value' [-Wunused-parameter]

   virtual void setBacklightPin ( uint8_t value, t_backlighPol pol ) { };

                                          ^

C:\Users\simon\Documents\Arduino\libraries\NewliquidCrystal/LCD.h:486:64: warning: unused parameter 'pol' [-Wunused-parameter]

   virtual void setBacklightPin ( uint8_t value, t_backlighPol pol ) { };

                                                               ^

C:\Users\simon\Documents\Arduino\libraries\NewliquidCrystal/LCD.h:505:40: warning: unused parameter 'value' [-Wunused-parameter]

   virtual void setBacklight ( uint8_t value ) { };

                                       ^

C:\Users\simon\Documents\Arduino\libraries\NewliquidCrystal\LiquidCrystal_I2C.cpp: In member function 'begin':

C:\Users\simon\Documents\Arduino\libraries\NewliquidCrystal\LiquidCrystal_I2C.cpp:149:1: internal compiler error: Segmentation fault

}

^

Please submit a full bug report,

with preprocessed source if appropriate.

See <http://gcc.gnu.org/bugs.html> for instructions.

lto-wrapper.exe: fatal error: C:\Program Files\WindowsApps\ArduinoLLC.ArduinoIDE_1.8.19.0_x86__mdqgnx93n4wtt\hardware\tools\avr/bin/avr-gcc returned 1 exit status

compilation terminated.

c:/program files/windowsapps/arduinollc.arduinoide_1.8.19.0_x86__mdqgnx93n4wtt/hardware/tools/avr/bin/../lib/gcc/avr/5.4.0/../../../../avr/bin/ld.exe: error: lto-wrapper failed

collect2.exe: error: ld returned 1 exit status

exit status 1
Fehler beim Kompilieren für das Board Arduino/Genuino Uno.

Dieser Bericht wäre detaillierter, wenn die Option
"Ausführliche Ausgabe während der Kompilierung"
in Datei -> Voreinstellungen aktiviert wäre.

Leider bekomme ich nach dem Einfügen von LCD Befehlen folgende Fehlermeldung

Ein Großteil sind nur Warnings.
Die kannst du erstmal ignorieren.

internal compiler error: Segmentation fault

Deine Tool Chain ist defekt.

Ein Up- oder Downgrade wird das Problem lösen.

Also:
IDE Deinstallieren und eine frische von dieser Seite installieren.

-->> Gleiches Problem!

Hallo und danke für die Hilfe!
Ich habe gerade meine IDE deinstalliert und von hier wieder aufgespielt. Die Version ist ja immer noch die 1.8.8 und der Fehler ist immer noch da. Soll ich eine ältere Version verwenden? Welche ist denn “robust”?

Danke!

Und hast du es auch mit der "portablen" Version probiert ?

Meinst du die Browser Version unter "Online Tools"?
Das habe ich soeben versucht. Nun kommen andere Fehlermeldungen wegen meinem Display.

Ich kann gerne den Quellcode zur Verfügung stellen. Hier reinkopieren macht bestimmt nicht so viel Sinn, da es fast 800 Seiten sind.

Marco81:
Meinst du die Browser Version unter "Online Tools"?
Das habe ich soeben versucht. Nun kommen andere Fehlermeldungen wegen meinem Display.

Hast du dir den Beitrag (Link von combie) nicht durchgelesen ?

Wie "800 Seiten", zu Anfang waren es 750 Zeilen.

Du solltest erst mal den Fehler beseitigen, bevor du weiter machst.

Doch, ich habe den durchgelesen. Darin finde ich zuerst den Hinweis:
"Er kann nur behoben werden, wenn man den Kompiler repariert, Updated oder eine ältere Version aufspielt."

Dann wird darauf hingewiesen, dass die Version aus dem AppStore zu Fehlern führen kann. Ich habe ja die Version von dieser Seite installiert. Daher dachte ich, die ist die richtige.
Vielleicht ist es auch ein Verständnisproblem meinerseits. Ich bin nicht der Jüngste und verstehe es vielleicht einfach nicht zu interpretieren, was ich genau machen soll.

Danke für eure Hilfe!

P.S. ich meine natürlich 800 Zeilen - entschuldigt das Missverständnis.

Marco81:
Hallo und danke für die Hilfe!
Ich habe gerade meine IDE deinstalliert und von hier wieder aufgespielt. Die Version ist ja immer noch die 1.8.8 und der Fehler ist immer noch da. Soll ich eine ältere Version verwenden? Welche ist denn "robust"?

Danke!

Ja, dann verwende mal eine Ältere, wenn es keine Neuere gibt.
Aber das sachte ich doch schon: Downgrade

Ich bin nicht der Jüngste und verstehe es vielleicht einfach nicht zu interpretieren, was ich genau machen soll.

Du bist selber für deine Taten verantwortlich!

Marco81:
Das habe ich soeben versucht. Nun kommen andere Fehlermeldungen wegen meinem Display.

Die Display Lib kann man sicherlich reparieren, so dass sie keine Fehler/Warnungen mehr wirft.
Vielleicht freut sich ja der Autor, wenn du ihm eine korrigierte Version zusendest.

Hallo nochmals,

mit der 1.8.7 funktioniert es nun.
Ich danke vielmals für die Unterstützung!

Marco81:
Meinst du die Browser Version unter "Online Tools"?
Das habe ich soeben versucht. Nun kommen andere Fehlermeldungen wegen meinem Display.

Zur abschließenden Erklährung:

Nein. Es gibt für Windows 2 versionen. Eine die Windows installiert und eine andere die Du nur in ein Directory Deiner Wahl entpackst (unzip). Auf der Downloadseite ist die 2 Option "Windows ZIP file for non admin install" genannt. Versuch's mal mit dieser. Mit dieser kan man auch verschiedene Versionen der IDE gleichzeitig auf dem PC haben. Versuch's mal mit der Aktuellen Version ( 1.8.8 ) und dann wenns nicht klappt mit älteren.

Wenns nicht klappt bitte gib uns die kompletten Fehlermeldungen.
Grüße Uwe

hier kann ich mich nur Uwefed anschliessen, da ich die Version aus dem Store hatte, nichts wirklich funktionierte. Die non admin Version rennt dagegen wie der Deibel persönlich.