File signature verification failed

Hello,

I have bought the Maixduino board from Sipeed, and wish to program it using Arduino IDE.

In File-Preferences Additional Board Manager URLs I have set the path:
http://dl.sipeed.com/MAIX/Maixduino/package_Maixduino_k210_index.json
This is correct; it finds the file.

However, when I use Board Manager to install the board, I get error message:

http://dl.sipeed.com/MAIX/Maixduino/package_Maixduino_k210_index.json file signature verification failed. File ignored.

I have tried deleting the Arduino15 folder and then restarting Arduino IDE, but the error persists.

I have searched the forum and found several posts on this problem, but there is not much advice on possible solution. One post suggests I launch a CDN refresh, but I have no idea how to do this.

"flash_999" has a post on Mar 29 2020 which says:
"Without making any further changes, the problem went away. This could indicate the issue might have been a transient network caching problem."

So, should I just wait for the problem to go away; might be a long wait ?

I'll be grateful for any advice; many thanks. Ken.

My PC is using Windows 10 Home, version 1903
Arduino IDE is version 1.8.9

If you open that URL (http://dl.sipeed.com/MAIX/Maixduino/package_Maixduino_k210_index.json) in your browser, does it successfully download the package_Maixduino_k210_index.json file?

If so, and you open the file in a text editor, does start like this:

{
    "packages": [
        {
            "name": "Maixduino",
            "maintainer": "Sipeed",
            "websiteURL": "https://maixduino.sipeed.com",
            "email": "support@sipeed.com",
            "help": {
                "online": "https://maixduino.sipeed.com"
            },
            "platforms": [
                {
                    "category": "K210",
                    "name": "Maixduino(k210)",
                    "version": "0.3.11",
                    "architecture": "k210",
                    "url": "https://dl.sipeed.com/MAIX/Maixduino/core/Maixduino_core_v0.3.11.zip",
                    "checksum": "SHA-256:03A7A7E245494460E581883AEB19CE01D7037E327940F5DF025971ECCA3AF235",
                    "archiveFileName": "Maixduino_core_v0.3.11.zip",
                    "size": "1905004",
                    "boards": [
                        {"name": "Sipeed Maix One Dock Board"},
                        {"name": "Sipeed Maix Bit Board"},
                        {"name": "Sipeed Maix Bit-Mic Board"},
                        {"name": "Sipeed Maix Go Board"},
                        {"name": "Sipeed Maixduino Board"},
                        {"name": "LamLoei AIoT DaaN Board"}
                    ],
                    "toolsDependencies": [
                        {
                            "packager": "Maixduino",
                            "version": "8.2.0_20190409",
                            "name": "riscv64-unknown-elf-gcc"
                        },
                        {
                            "packager": "Maixduino",
                            "version": "1.0.2",
                            "name": "kflash"
                        }
                    ]
                },

or do you see something else. The reason I ask is because I have seen one or two reports where someone was having the problem of the network security system actually replacing the downloaded files with some HTML, I guess in an attempt to be helpful, but actually doing just the opposite.

I forgot to add that I just installed the "maixduino" platform using that URL here and had no problems.

Hi pert,

Yes, I have successfully downloaded and opened the json file, and it starts exactly as your code snippet, including the checksum which is same as in yours.

Update -- Problem Solved.

I have installed the latest version of Arduino IDE, 1.8.13, and all is now OK.
No "file signature verification failed" message.

Should I mark this topic as closed ?
I'm not sure how to do this; can I leave it to the moderator ? Thanks, Ken.