Firmware not compiling for MKR Wifi1010

Hi everyone,
I’ve been using the MKR Wifi1010 board for a couple of weeks. I previously went through the process of updating the firmware to the latest version with no problems. However, I tried to load the code to check the firmware version (Examples->WifiNINA->Tools->CheckFirmwareVersion) but I get an error that says I have an error compiling for the Arduino MKR Wifi1010 board. I’ve also tried loading the Firmware Updater example and I get the same error code.

Arduino: 1.8.10 (Windows 10), Board: "Arduino MKR WiFi 1010"

In file included from C:\Users\MyName\AppData\Local\Arduino15\packages\arduino\tools\CMSIS-Atmel\1.2.0/CMSIS/Device/ATMEL/samd21/include/samd21.h:69:0,

                 from C:\Users\MyName\AppData\Local\Arduino15\packages\arduino\tools\CMSIS-Atmel\1.2.0/CMSIS/Device/ATMEL/samd.h:105,

                 from C:\Users\MyName\AppData\Local\Arduino15\packages\arduino\tools\CMSIS-Atmel\1.2.0/CMSIS/Device/ATMEL/sam.h:540,

                 from C:\Users\MyName\AppData\Local\Arduino15\packages\arduino\hardware\samd\1.8.4\cores\arduino/Arduino.h:48,

                 from sketch\CheckFirmwareVersion.ino.cpp:1:

C:\Users\MyName\AppData\Local\Arduino15\packages\arduino\tools\CMSIS-Atmel\1.2.0/CMSIS/Device/ATMEL/samd21/include/samd21g18a.h:237:10: fatal error: core_cm0plus.h: No such file or directory

 #include <core_cm0plus.h>


compilation terminated.

exit status 1
Error compiling for board Arduino MKR WiFi 1010.

Does anyone know why? I’ve gone to my Library Manager and made sure I’ve got all the libraries updated (I’m using the WifiNINA v.1.4.0, etc.). Any thoughts?

I'm not sure what happened but I think somehow my SAMD Boards Library had gotten corrupted. I uninstalled the Arduino IDE and went back through re-installing everything and now its compiling fine. Sorry about the trouble.