Firmware Updater - Nano 33 IOT

I have a Nano 33 IOT, and for something that I have in mind to try I need to load an SSL certificate on it.

Reading around, this can be done with the Firmware Updater which is available in the Tools menu of the IDE. There is also an associated FirmwareUpdater sketch which is part of the WiFiNINA library. More on this later. There is also a CheckFirmwareVersion sketch with the same library. Running it it produces this output

WiFiNINA firmware check.

Firmware version installed: 1.2.3
Latest firmware version available : 1.2.1

Check result: PASSED

Note that the output does not make sense

Running the FirmwareUpdater sketch produces this output

Unable to communicate with ESP32 boot ROM!

Obviously this is not a good sign either

Running the Firmware Updater from the menu produces this screen from which the Nano 33 IOT selectable but it does not appear in the "select firmware" list


Selecting Test Connection produces this error message

However, the FirmwareUpdater sketch is loaded on the board and has been compiled, see above

Just to be sure I clicked on the Open Updater sketch button but nothing happens

Background information :
Genuine Nano 33 IOT - loads and runs WiFiNINA examples OK
Windows 10
IDE version 1.8.10
WiFiNINA library version 1.4, which is the latest version on GitHub

Has anyone got any ideas how to update the firmware/load SSL certificates ?
There are previous threads on here asking for help with the same problem but none was forthcoming

1200 views and no replies says it all :cry:

I think it's in the works:

Probable it's already possible to do it by pulling in the various parts from GitHub. I haven't had a chance to look at it carefully to see what that would involve. I'll try to get to it later today and will let you know what I find out.

Thanks Per

1st step, update the WiFi101 / WiFiNINA Firmware Updater plugin to 0.10.10:

As an alternative, you can just download and use the test build of the Arduino IDE from here:
https://github.com/arduino/Arduino/pull/9552#issuecomment-568559249
Which is a bit easier, but also means downloading the entire IDE instead of just that 7 MB plugin.

2nd step, update the WiFiNINA library to the development version:

3rd step, upload the WiFiNINA library’s FirmwareUpdater sketch to your Nano 33 IoT:

  • File > Examples > WiFiNINA > tools > FirmwareUpdater
  • Sketch > Upload

4th step, Update the SSL root certificates:

  • Tools > WiFi101 / WiFiNINA Firmware Updater
  • Select the port of your Nano 33 IoT from the list under “1. Select the port of the WiFi Module”.
  • Click the “Add domain” button and add the domain.
  • Click the “Upload Certificates to WiFi module” button.

You can also use the WiFi101 / WiFiNINA Firmware Updater to update the NINA firmware to 1.3.0 if you like.

Thanks Per. I will give it a try

Certificates and firmware updated now after following the instructions

Yay! Glad to hear it worked.

Now to work out how to actually connect to an SSL site

Amusingly the example sketch for the WiFiSSLClient does not actually connect to an SSL site at all as it seems to have been lifted from the normal client example

char server[] = "www.google.com";    // name address for Google (using DNS)

Hi, I've had this same problem, over 6 months later. I tried the solutions above, and they unfortunately didn't work. I'm on a custom board that is a clone of the Nano IoT 33 almost, with some modifications. Any other ideas on how I can troubleshoot this? I'm on the latest version of Arduino IDE on mac and the latest version of the WifiNina library (1.5.0).

Sorry, but I have no ideas apart from following the instructions above which worked for me

It appears to me from the little I have used them that the Nano 33 range is still in something of a shakedown phase. Since it worked for him, can you try the exact same software versions that UKHeliBob was using?

It appears to me from the little I have used them that the Nano 33 range is still in something of a shakedown phase.

That is my impression too.

I have put my 33 IOT aside for now as amongst other things I was having problems with the Serial interface, which changes automatically to another port during upload and for me it did not always change back. Whether this was the fault of the board, my USB hub (powered) or my PC (Windows 10) I never got to the bottom of