Firmwhere Update For 3D Printer Not Ulpoading.

Hello,

Please be patient is I am a self protested noob. I and Arduino have never got on any of my projects and we still are not friends.

I have bought a 3D printer but they require me to update the firm where using Arduino. I have downloaded the document they have told me to, I have installed the board and added that to the IDE. Without editing the document I hit upload with the printer on and connected and I get an error in compiling.

I am running Arduino 1.6.8 on windows 10. The board is Sanguino ATmega 1284p 16mhz. I have bought the Vector 3 3D printer (I don't recommend it as its full of basic design flaws but I did as it didn't show £600 in my bank statement hahaha)

I have emailed them about it but they haven't helped me for over a month so I turn to you. The instructions loo like they are using an older version of Arduino but I cant tell witch one. I also had to figure a lot of it out myself because the instructions don't explain anything and assume you know and have done so much. I have a few projects pending the fix of this printer so any help is appreciated.Thank you for reading.

Gig.

What is the firmware that you have (Marlin)? Please post the exact and complete error text.

Thank you for you quick response. The file is called Sprinter Melzi.

Arduino: 1.6.8 (Windows 10), Board: “Sanguino, ATmega1284 or ATmega1284P (16 MHz)”

C:\Program Files (x86)\Arduino\arduino-builder -dump-prefs -logger=machine -hardware “C:\Program Files (x86)\Arduino\hardware” -hardware “C:\Users\Christopher\AppData\Local\Arduino15\packages” -tools “C:\Program Files (x86)\Arduino\tools-builder” -tools “C:\Program Files (x86)\Arduino\hardware\tools\avr” -tools “C:\Users\Christopher\AppData\Local\Arduino15\packages” -built-in-libraries “C:\Program Files (x86)\Arduino\libraries” -libraries “C:\Users\Christopher\Documents\Arduino\libraries” -fqbn=Sanguino:avr:sanguino:cpu=atmega1284p -ide-version=10608 -build-path “C:\Users\CHRIST~1\AppData\Local\Temp\builde37b81838f45c3e83dfe1ec9aa68da9c.tmp” -warnings=none -prefs=build.warn_data_percentage=75 -verbose “C:\Users\Christopher\Documents\3D\firmwhere\Sprinter_Melzi\Sprinter_Melzi.ino”
C:\Program Files (x86)\Arduino\arduino-builder -compile -logger=machine -hardware “C:\Program Files (x86)\Arduino\hardware” -hardware “C:\Users\Christopher\AppData\Local\Arduino15\packages” -tools “C:\Program Files (x86)\Arduino\tools-builder” -tools “C:\Program Files (x86)\Arduino\hardware\tools\avr” -tools “C:\Users\Christopher\AppData\Local\Arduino15\packages” -built-in-libraries “C:\Program Files (x86)\Arduino\libraries” -libraries “C:\Users\Christopher\Documents\Arduino\libraries” -fqbn=Sanguino:avr:sanguino:cpu=atmega1284p -ide-version=10608 -build-path “C:\Users\CHRIST~1\AppData\Local\Temp\builde37b81838f45c3e83dfe1ec9aa68da9c.tmp” -warnings=none -prefs=build.warn_data_percentage=75 -verbose “C:\Users\Christopher\Documents\3D\firmwhere\Sprinter_Melzi\Sprinter_Melzi.ino”
“C:\Program Files (x86)\Arduino\hardware\tools\avr/bin/avr-g++” -c -g -Os -w -std=gnu++11 -fno-exceptions -ffunction-sections -fdata-sections -fno-threadsafe-statics -w -x c++ -E -CC -mmcu=atmega1284p -DF_CPU=16000000L -DARDUINO=10608 -DARDUINO_AVR_SANGUINO -DARDUINO_ARCH_AVR “-IC:\Program Files (x86)\Arduino\hardware\arduino\avr\cores\arduino” “-IC:\Users\Christopher\AppData\Local\Arduino15\packages\Sanguino\hardware\avr\1.0.0\variants\sanguino” “C:\Users\CHRIST~1\AppData\Local\Temp\builde37b81838f45c3e83dfe1ec9aa68da9c.tmp\sketch\Sprinter_Melzi.ino.cpp” -o “nul”
“C:\Program Files (x86)\Arduino\hardware\tools\avr/bin/avr-g++” -c -g -Os -w -std=gnu++11 -fno-exceptions -ffunction-sections -fdata-sections -fno-threadsafe-statics -w -x c++ -E -CC -mmcu=atmega1284p -DF_CPU=16000000L -DARDUINO=10608 -DARDUINO_AVR_SANGUINO -DARDUINO_ARCH_AVR “-IC:\Program Files (x86)\Arduino\hardware\arduino\avr\cores\arduino” “-IC:\Users\Christopher\AppData\Local\Arduino15\packages\Sanguino\hardware\avr\1.0.0\variants\sanguino” “C:\Users\CHRIST~1\AppData\Local\Temp\builde37b81838f45c3e83dfe1ec9aa68da9c.tmp\sketch\Sprinter_Melzi.ino.cpp” -o “C:\Users\CHRIST~1\AppData\Local\Temp\builde37b81838f45c3e83dfe1ec9aa68da9c.tmp\preproc\ctags_target_for_gcc_minus_e.cpp”
In file included from C:\Users\Christopher\Documents\3D\firmwhere\Sprinter_Melzi\Sprinter_Melzi.ino:8:0:

C:\Users\CHRIST~1\AppData\Local\Temp\builde37b81838f45c3e83dfe1ec9aa68da9c.tmp\sketch\Sprinter.h:3:22: fatal error: WProgram.h: No such file or directory

#include <WProgram.h>

^

compilation terminated.

exit status 1
Error compiling for board Sanguino.

Hope this helps. Thanks again.

WProgram.h: No such file or directory

#include <WProgram.h>

There is the first problem. WProgram.h is for ancient versions of the IDE. The newer versions use arduino.h. Repace any instances of WProgram.h with arduino.h and see if it will compile.

Thank yo so much, I am experiencing some technical difficulties with my computer so ill try that when it gets back from the IT guys. It makes sense and sounds exactly my problem so ill get back on how successful it is. Thanks again.

HHHmmmmm... I ran a word find in word with the serch of .h and it cam up with suggestions but none where WProgram.h I am not sure what else to do sorry.

WProgram.h is included in many of the .h files. You may be better off looking into Marlin firmware. Marlin is, I believe, written from Sprinter and is much newer. I am pretty sure that you can set up Marlin for your Melzi board.

I checked and there Is a pin definition file for Melzi in Marlin.
https://github.com/MarlinFirmware/Marlin/tree/RC/Marlin

I suppose that another option is to use and old version of the IDE.
https://www.arduino.cc/en/Main/OldSoftwareReleases#00xx

You maybe right. Ill get my computer fixed before attempting to fix my printer but I have also found a thread about not finding Wprogam.h I think that will also help me. At least I know what roughly to do now. Thanks for the links and Ill let you know how I do.

Good luck! My 3d printer is my favorite toy and I have actually had people pay me to use it.

I belieive I have found all the WProgram.h and changed them to arduion.h but now it is saying "pasting "/* (extruder)*/" and "_DDR" does not give a valid preprocessing token"

#define HEATER_0_PIN 13 // (extruder) is the code highlighted. As always I have the full message. Thank you and sorry for being a pain.

Please post the exact and complete error text. The hiighlighted line may not be where the error really is (the error is sometimes in the line before).

arduion.h is not arduino.h or was that a typo?

Just a typo. I was damnsum careful about that.

Its too big to paste in sorry.

I have to download an app to look there. I don't want to. You are having so much trouble with this that I must wonder why you can't try a newer (better, probably) firmware like Marlin or Repetier that is compatible with the newer IDE versions. Or as I suggested before get a version of the IDE that will work with the firmware you have.

what is the youngest version that works with WProgram.h? because the version they used, when I try to download it says 404 error not found. at least then I can isolate all the versions that run it.

Here is an interesting post concerning Wprogram.h. http://forum.arduino.cc/index.php?topic=128597.0

It seems you need a version prior to 1.0. I tried the link to older versions that I provide before and was able to download 0023. I have not tried to install it, though.

I have the solution. Don't worry, In the update they give you the version they use so I am down dating now. If you need anything from me, name it I owe you. Thanks. They gave you everything I think but I think you've told me what to do with it so thanks. should have a print soon.

Ok, so the firm where has updated or the sketch uploaded successfully. Thanks. But its not changed a thing. Thanks for getting me this far. If you need anything from me I owe you one. Ill call tech support and see what they say unless you have any other words of advice. But it uploaded and that's progress. What I wanted shame it didn't fix anything. Thanks again.

The setting for the printer are in a file called configuration.h. You can edit parts of that file to get the firmware to work with your printer. What are the problems that you have? Maybe its just a bad setting or two.

Thanks again, no it was the print head not tripping the limit switch. I have bent the metal on the switch and it clicks. now the motor stops and completes the sequence. I had to strip it butt naked but I think its fixed. Thanks again, I am forever in your debt. you have thought me so much.