(Fixed) Unable to register

First, I'm using a friend's login, setup just so I could get (hopefully) a resolution to being unable to register.

I "registered" with the forum back in early January. However, I never got an activation email. I tried registering again with both of my other email accounts (but at the same service, isp.com) but nothing I tried worked. Finally I sent an email to info@arduino.cc. There was no reply. Then I sent an email to web@arduino.cc. There was no reply. In the meantime, I did see that other people had registered while I couldn't, so I knew the forum system was operative.

So, last night I asked a friend to register and of course he had no problem. He also registered another account using my email address. Again, I never received an activation email from the forum system. Yes, I have checked the SPAM folder, etc.

Apparently, my internet service provider (isp.com) seems to have a problem getting any email from this forum, OR, the forum has a problem with my internet service provider.

I'd really like to register under my own account rather than my friend's. So, can this issue be resolved?

Regards, John

if your ISP filters arduino.cc mail you could open a gmail account.

You can fetch your gmail messages into your normal email account (most providers have such option) and email programs like outlook certainly can.

My ISP no longer uses its own email but instead uses Google. There is no record on the Google webmail link which shows any mail from Arduino.cc in either the received mail or SPAM boxes.

I hadn't thought to do so, but I'll query my ISP about this anomaly.

Regards, John

I "registered" with the forum back in early January.

Account name?

I believe the user name originally was “amazed”, however, I have tried various names since then while trying my other email accounts, so what the system may show could be anything, unfortunately, from a troubleshooting perspective.

I’ll try to register again with “amazed” as a user name; hopefully that may establish a base line again.


edit: Moderator(s)…For some reason, I was able to register via one of the email addresses that had failed before. Though it shouldn’t have made a difference, I had tried “one more time” but this time I was using my laptop. After registering, I had to leave home for a few hours and when I returned I found the activation email. I suspect that my trying to register several times in a short time frame may have caused the forum system to lockout/ignore the original 2 addresses I had used. I tried changing the email address I used to register back to the original and never got a response, so my original email address is indeed “hosed”. Coincidently, I got an email from David Cuartielles and he got the email address changed. Sorry for the long post but thought it might help others. Thanks, again, David!