Flash atmega8 via ICSP with ESP8266 and Arduino_WiFi_AVRISP problem

Hello,

In this post (https://forum.arduino.cc/index.php?topic=651260.0), the last comment said Windows avrdude does not support NET upload with the -P command.

I have made some tests, and in reality i suspect that maybe the package is malformed when sending data to the ESP8266 because i do get data flowing having the esp connected to serial while using the NET command, and ESP for sure receives some data. avrdude version i'm using is the latest from arduino 1.8.13 which is 6.3-20190619.

The command i'm running is :

avrdude -v -c arduino -p atmega8 -P net:192.168.1.90:328 -Uflash:w:Blink.ino.hex:i

I'm always receiving the same error, when starting to flash, wich is :

avrdude: ser_drain(): read error: ParamÞtre incorrect.

avrdude: ser_drain(): read error: ParamÞtre incorrect.

avrdude: ser_drain(): read error: ParamÞtre incorrect.

Now i also have a ubuntu machine and when i run the exact same command in the ubuntu
i actually am able to flash the sketch to the ATMEGA8 so, unless i'm wrong, there must be
some issue with the compiled version of avrdude for windows or with some windows libraries that is making this behavior
this would be a neat feature to work on windows too, i know i can program the atmega8
with a avrisp like programmer, the point here is not finding an alternative programmer
is making the Arduino_WiFi_AVRISP sketch work as intended on Windows.

Now my question is if you know about this problem and if you do if there is a pipeline
to try and fix why this is not working.

Thanks in advance.