FLC100 magnetic sensor

hi , friends
i decide to detect current or voltage with FLC100 magnetic sensor. this sensor has 5 pins :
0v , +5v , sync , out- and out + .
sshot-1.png is my circuit in attachment

my source code :

int sensorPin = A0;
int sensorValue;
void setup() {
  pinMode(ledPin, OUTPUT);
  Serial.begin(9600);
}

void loop() {
  sensorValue = analogRead(sensorPin);
  delay(sensorValue);
  Serial.println(sensorValue);
  delay(200);
}

serial monitor :

0
3
0
0
4
0
3
0
0
4
0
5
0
4
5
2
5
0
0
3
5
0
0
0
3
6
2
0
0
0
0
3
4
6
5
0
0
0
0
0
0
3
3
6
6
2
0
0
0
1
4
6
3
0
0
0
1
1
2
3
4
5
5
3
0
0
0
0
0
0
1
2
4
5
4
0
0
0
0
0
1
3
5
5
3
0
0
0
0
0
0
0
2
4
5
4
0
0
0
0
0
0
0
0
0
0
3
1
0
3

how can i fix this problems ?
plz help me to detect votage or current . TNX ALL

You need a common ground between your sensor and Arduino.

Also the output can be + or - 2.5V so you better bias it to that before putting it into the Analogue input.

Hi, Can you post link to supplier/datasheet/specs of the FLC100?

Thanks.. Tom... :)

Here Tom http://www.stefan-mayer.com/images/datasheets/Data-sheet_FLC-100.pdf

Grumpy_Mike: You need a common ground between your sensor and Arduino.

Also the output can be + or - 2.5V so you better bias it to that before putting it into the Analogue input.

Hi , Mike my circuit GND is common between Arduino and sensor. figure of my circuit : |500x375

the output is about +100 ma not + or - 2.5v when i connect + and - out to the multimetr the sensor can detect the magnetic and show 2.5 v (when i near ND magnet)

Hi,

the output is about +100 ma not + or - 2.5v

How did you measure 100mA?

Rather than your picture, can you please post a copy of your circuit, in CAD or a picture of a hand drawn circuit in jpg, png?

Thanks.. Tom.. :)

Hi, Where is the blue wire going? Where is the wire you are measuring the magnetic field from, with the current flowing through it?

Tom.. :)

my circuit GND is common between Arduino and sensor.

The thing is a schematic is supposed to show the wiring you have, we can only comment on what you show us. Also what you report shows all the symptoms of a floating input, or an input going below zero. Your picture does not show connection of the Analogue pin.

when i connect + and - out to the multimetr the sensor can detect the magnetic and show 2.5 v (when i near ND magnet)

And does this change to minus 2.5V as you rotate the magnet, according to the data sheet it should. As I said I would bias the analogue input, in this case with two 47K resistors, one to 5V and the other to ground. Also change the sensor input pin to just zero not A0.

Grumpy_Mike: You need a common ground between your sensor and Arduino.

Also the output can be + or - 2.5V so you better bias it to that before putting it into the Analogue input.

hi : |500x288

the blue wire go to +multimetr . and -multimetr go to gnd

Grumpy_Mike: The thing is a schematic is supposed to show the wiring you have, we can only comment on what you show us. Also what you report shows all the symptoms of a floating input, or an input going below zero. Your picture does not show connection of the Analogue pin. And does this change to minus 2.5V as you rotate the magnet, according to the data sheet it should. As I said I would bias the analogue input, in this case with two 47K resistors, one to 5V and the other to ground. Also change the sensor input pin to just zero not A0.

my analog connection is blue wire . and it connected to A0 . but in this pic doesn't show it .

excuse me , Can you send a schematic for me plz ?? who can i bayas thee analog output (+out) ? do you mean this :

|500x375

this circut bord work but flc100 detect iron and current . what should i do ? i decide to show current not iron .

my bord React iron . and this is bug for my circut bord. what shod i do for ths problems ?

at the end whats your idea for detect votage or current ?

tnx .

who can i bayas thee analog output (+out) ?

I told you in reply #7. Incase you missed it I will tell you again.

two 47K resistors, one to 5V and the other to ground.

You still need a common ground which your schematic STILL does not show, and now the latest picture shows you have removed from the circuit.

So the red wire needs to be connected to the analogue input, and the white wire needs to be where it is but also to be connected to the ground.

this circut bord work but flc100 detect iron and current

That sentence is a nonsense.

my bord React iron . and this is bug for my circut bord.

I think you have got a bit confused as to what the sensor is doing. It is detecting a change in magnetic field, so iron will effect the reading as will a magnet. That is what the board does. Their is no way of differentiating the effect of iron or a magnet.

Hello, Masters, I need FLC-100 circuit diagram, can you send me a circuit diagram, to my email, my e-mail; gqhhqg75@gmail.com

gqhhqg75@gmail.com

i need this project. if its complete and fixed please send it here آردوینو

i need this project. if its complete and fixed please send it here

Seeing the initial post was based on a complete misunderstanding of what the sensor could measure or detect, then the project can't possibly exist. Did you not understand this from reading the thread?

If you have other requirements then please start your own thread, this one is dead and is not going anywhere.

Hello, master. I made a few magnetometers. I want to know how to connect the back circuit. Can I exchange the detailed circuit diagram and source code

My email address: gqhhqg75@gmail.com

If you have other requirements then please start your own thread, this one is dead and is not going anywhere.