floats on attiny85?

I've got an attiny85 with the mirf24l01 and dallas temperature library for the ds18b20, everything works until I go to get the vlues from the temperature sensor, I believe it has to do with the floats math in the dallas library, because I can replicate it by trying to do float math
the actual error is some sort of compiler error something about being truncated
I guess I could alter the library to not use floats altho I imagine it would be easier to fix the floats problem

by any chance is something to do with truncation actually something to do with PCREL?

If so, look in the Microcontrollers section of the forum for the fix.

Ah yes! Relocation truncated to fit :R_AVR_13_PCREL against symbol exit defined in. Fini9 section blah blah blah

Hmmm tried that and still haaving problems, it says symbol pinmode, digital and a few others too not just exit

You are going to need to post the actual errors, and the code that is causing the problem else it is not possible to help further.

Well the code that causes it is

 tempF = tempF / .0625;

And the errors are like I said before with exit and a few other things

winner10920:

 tempF = tempF / .0625;

Instead of dividing by .0625, try multiplying by 16.

winner10920:
And the errors are like I said before with exit and a few other things

You are going to have to be a whole lot more specific. The simplest thing to do is to just copy and paste the actual error message.

Perhps ill try that multiplication idea,
ill post the actual errors after work, I have to type it out, don't have internet on my laptop

If you have a camera, you could just take a photo of the errors.

Now that's a genius idea, ill get that up later

I saw your other pcrel post, could you post that zip file here? Perhaps I didn't do something right when I tried the instructions on that page, I tried downloading your patch from tht post but the download would fail everytime

I have posted it again in my first post of the other thread. You may be having problems because the zip has spaces in the name, so I posted another copy with a different name.

Second one worked, ill post pics of the errors and try that patch first

(so in case it isn’t obvious from the conversation, there is no reason that floats should not be expected to work on the tiny85. The “pcrel” errors we’re thinking about are related to sketch size, which would naturally increase quite a bit once the floating point libraries are included, but they don’t specifically have anything to do with the math.)

Ok, I still have yet to try the patch, been real busy at work lately, too tired when I get home, hopefully today ill get to it

I mustve made a mistake when I tried to patch it, your patch worked right away
thanks for your patience and time figuring that out, saved me a ton of pain trying to figure out something that wasn't broken

If it didn't work the first time, it may just be that you didn't close and open Arduino. But glad it worked, that error annoyed me for a while too.