fonctionnement basic de arduino

Merci de bien vouloir m’aider
Après avoir installé arduino
Essai pratique avec Blink

  1. Sur un ordi windows 7 64 bits fonctionnement impeccable. La vérification se fait sans problème, pas de message d’erreur
  2. Sur un autre ordinateur windows XP 32 bits Même version d’arduino 1.6.6 .
    Pouvez vous m’aide à éclaircir ce problème ?
    Ou sont les causes de l’erreur de compilation ?
    Comment y remédier ?
    Merci beaucoup
    Dans ce cas message d’erreur systématique

Arduino:1.6.6 (Windows XP), Carte : “Arduino/Genuino Uno”

C:\Program Files\Arduino\arduino-builder -dump-prefs -logger=machine -hardware “C:\Program Files\Arduino\hardware” -tools “C:\Program Files\Arduino\tools-builder” -tools “C:\Program Files\Arduino\hardware\tools\avr” -built-in-libraries “C:\Program Files\Arduino\libraries” -libraries “C:\Documents and Settings\Puyo\Mes documents\Arduino\libraries” -fqbn=arduino:avr:uno -ide-version=10606 -build-path “C:\DOCUME~1\Puyo\LOCALS~1\Temp\build08e4957f02c018eb579e11ddc64f9701.tmp” -warnings=all -prefs=build.warn_data_percentage=75 -verbose “C:\Program Files\Arduino\examples\01.Basics\Blink\Blink.ino”
Exception 0xc000001d 0x1003f 0x0 0x503f39
PC=0x503f39

math.init•1()
c:/go/src/math/pow10.go:34 +0x19
math.init()
c:/go/src/math/unsafe.go:21 +0x3f
strconv.init()
c:/go/src/strconv/quote.go:455 +0x45
os/exec.init()
c:/go/src/os/exec/lp_windows.go:123 +0x54
main.init()
c:/jenkins/workspace/arduino-builder-windows/main.go:392 +0x49

goroutine 2 [runnable]:
runtime.forcegchelper()
c:/go/src/runtime/proc.go:90
runtime.goexit()
c:/go/src/runtime/asm_386.s:2287 +0x1

goroutine 3 [runnable]:
runtime.bgsweep()
c:/go/src/runtime/mgc0.go:82
runtime.goexit()
c:/go/src/runtime/asm_386.s:2287 +0x1
eax 0x10c7c068
ebx 0x62bd88
ecx 0x10c72000
edx 0x62bd88
edi 0x0
esi 0x4c38
ebp 0x0
esp 0x10c7bf88
eip 0x503f39
eflags 0x10206
cs 0x1b
fs 0x3b
gs 0x0
arduino-builder a retourné 2

Erreur de compilation.

Bonjour,

Je serai toi, je mettrai java à jour et je réessayerai.

https://www.java.com/fr/download/

si je veux mettre java a jour sur mon xp, java m'informe que mon os est trop ancien pour la nouvelle version de java mais que je peux continuer à mes risques et périls.....

alors installe une ancienne version de l'IDE

https://www.arduino.cc/en/Main/OldSoftwareReleases#previous

Merci pour la rapidité des réponses Merci à Kamill et Dfgh . J’ai désinstallé java , puis réinstallé mais sans amélioration pour arduino. Merci à dfgh désinstallé arduino , puis réinstallé . Et l& nette amélioration . Mais cependnat encore deux erreurs de compilation . Avec le message suivant

Core.a(main.cpp.o) : In function ‘main’ C:\Program Files\Arduino\hardware\arduino\cores\main.cpp:40: undefined reference to ‘setup’ C:\Program Files\Arduino\hardware\arduino\cores\main.cpp:43: undefined reference to ‘loop’

dans le prg que tu compile, il n'y a pas de set up et de loop

testes plutot en compilant un prg d'exemple que tu trouveras dans "fichier" "exemples" puis en première ligne "basic" et ensuite "blink"

merci cela fonctionne
merci à dfgh ainsi qu’à cmill
j’espère que maintenant je vais pouvoir continuer ( seul )mon apprentissage.
je ne pensais pas avoir une aide aussi rapide
merci encore