Font are not display on android

hi forom piople

i have a big problem that i dont succsed to solved for long time

Setup description :
i used with the NodeMcu ESP8266 as a web server

Problem : font are not display on android but can be shwon on iPhone and regular web brouser

please find below the code - it very simple , see the attached output picture

<

const char homePage PROGMEM = R"=====(

Engineering Project body{ margin-top: 10px; font-family: Times New Roman; background-color:#333333; -webkit-background-size: cover; -moz-background-size: cover; -o-background-size: cover; background-size: cover; } h1{ font-size: 3.5em; /* 40px/16=2.5em */ margin: 0px auto 10px; } .buttonSetup { display: block; width: 130px; background-color: 2c3e50 ; border:4px solid #DAA520; color: #DAA520 ; padding: 30px 30px; text-decoration: none; font-size: 50px; margin: 0px auto 50px; cursor: pointer; border-radius: 10px; } .Cut { display: block; width: 130px; background-color: 2c3e50 ; border:4px solid #DAA520; color: #DAA520 ; padding: 30px 30px; text-decoration: none; font-size: 50px; margin: 0px auto 1px; cursor: pointer; border-radius: 10px; } .header_cut { background-color: #333333; border-width: 4px; border-color: yellow; color: #f2f2f2; padding: 1px 1px; display: inline; } .button { display: block; width: 180px; background-color: 333333 ; border:4px solid #DAA520; color: #DAA520 ; padding: 13px 30px; text-decoration: none; font-size: 50px; margin: 0px auto 5px; cursor: pointer; border-radius: 4px; } .header_button { background-color: ; border-width: 7px; border-color: yellow; color: #f2f2f2; padding: 15px 10px; } .Cut { background-color: #333333; color: white; border-width: 7px; border-color: #cccccc; } .buttonSetup { background-color: #333333; color: white; border-width: 7px; border-color: #cccccc; } .button-off:active {background-color: #2c3e50;} .my_button:active {background-color: white;}

  Engineering Project  




Start to Cat

>

thanks a lot on your help !!!

andruid display problem.PNG

I’ve deleted your other cross post @eran1234.

Cross posting is against the rules of the forum. The reason is that duplicate posts can waste the time of the people trying to help. Someone might spend 15 minutes writing a detailed answer on this thread, without knowing that someone else already did the same in the other thread.

Repeated cross posting will result in a suspension from the forum.

In the future, please take some time to pick the forum section that best suits the topic of your question and then only post once to that forum section. This is basic forum etiquette, as explained in the sticky “How to use this forum - please read.” post you will find at the top of every forum section. It contains a lot of other useful information. Please read it.

Thanks in advance for your cooperation.

Please use code tags when you post code or warning/error messages. To do this, click the </> button on the forum toolbar, then paste the text you want to be in the code tags. Finally, move the cursor out of the code tags before adding any additional text you don’t want to be in the code tags. If your browser doesn’t show the posting toolbar, then you can manually add the code tags like this:
[code]``[color=blue]// your code is here[/color]``[/code]

The reason for doing this is that, without code tags, the forum software can interpret parts of your code as markup, leading to confusion, wasted time, and a reduced chance for you to get help with your problem. This will also make it easier for us to read your code and to copy it to the IDE or editor.

Using code tags and other important information is explained in the “How to use this forum” post. Please read it.

When you attach an image, it’s helpful to also embed it in the post following these instructions

That will allow people to easily view the image rather than having to download it.

Can’t not display on Android?
Sounds like a problem with your webpage or possibly with your smartphone.