Forum configured by rogue clowns?

Why is the forum software (YaBB) so poorly configured? The quote button exists on the list of the last X posts but not within actual topics themselves. The button to modify your own profile doesn't exist. You can still do it if you know the proper YaBB url though. I'm sure that there are other misconfigurations that I'm missing.

Is the forum intentionally poorly configured or what? I'm posting this because I saw another post about the quoting misconfiguration. That problem annoys me to no end!

So fix it. What are the steps required to make it work?

Well, while I do have a bit of experience in administering a YaBB board, I've never seen one that has the sort of weird configuration that this one does. It's not normal, someone has done something, intentional or not, to mess up the way that the board works. I don't, off hand, know what that is.

I'd have to sniff around in the Admin panel of a board I have admin access to. Maybe I can figure out what has happened. It's likely that it wasn't intentional and who knows what sort of things have been done to make it the way it is.

I doubt that insulting the hard working volunteer(s) that administer the board will serve your cause :wink: But I do agree that forum users would benefit from the changes.

Adding the button to configure profile and putting the quote option back into the threads would be a big help.

And for those of us that like to review what's been going on over the previous night, increasing the action=recent;display=x maximum value to at least 50 and ideally 100 would save trawling through every thread.

.. and with great effort, you can make it so that it's almost but not quite as useful as an email list or usenet newsgroup.

Kids, reinventing the wheel with a glitzy "web 2.0" interface. :slight_smile:


Mem, yes you are right. I shouldn't be so critical of the people behind the scenes. I tend to word things a bit strongly.

I just cannot figure out:

  1. How the forum software got so messed up in the first place
  2. Why no one with admin access has fixed it yet

I also agree with kg4wsv. A newsgroup would probably be better anyway. However, YaBB is NOT a web 2.0 application. Web 2.0 infers AJAX type methods. YaBB is an old school web app written in perl.

YaBB is NOT a web 2.0 application

yeah, I know. it's not a wheel, either. I guess my attempts at humor are too odd for most folks.

The thing I'd like most to see is a functional RSS feed. That would let me use the reader of my choice, anyway.


I have always wondered why the forum has a YABB logo at the top instead of the Arduino one too.

It isn't great btu I am sure there are members that can help out to make it better.

Where is the profile button supposed to be? Is it an image? I don't see an option in the admin settings that would be disabling it (or removing the quote buttons). Any ideas?

Between "Members" and "Logout".

Honestly, this just looks like a forum that was upgraded or transferred incorrectly. There can be plenty of changes between versions of forum software, enough to account for the problems we're seeing.

Maybe it's time to try again, the current version of YaBB is 2.3.1 already.

Hmmm that could be... I've upgraded a YaBB board from something like 1.3 up to 2.1. Hit some snags at first but it's reasonable now. I remember it wasn't as easy as I would have liked.

The best thing to do is setup a new installation of YaBB and then migrate the forums, posts, and users. That way any problems that might have accumulated in the program files (html and perl) are dead and you essentially have a fresh install with the old messages.

Obviously this should be done as a test elsewhere first until all the bugs are worked out and you are comfortable with the transition.