FPGA.analogWrite had no output

I just recieved the hardware and try to test the FPGA PWM output.
Using VidorPeripherals library 1.1.0.
FPGA.analogWrite(33,64); has not out put on pin A0.

The VidorTestSketch works on the same setup.
I can get output on A0 with FPGA.digitalWrite(33, HIGH);

By the way, what is the max frequency I can set with FPGA.analogWriteResolution(int bits, int frequency)?

Thank you!

I just did little digging around in fpga files + libraries.

Did you set:
FPGA.pinMode(33, VIDOR_PWM);

Thank you for your prompt reply!
I tried your suggestion and it does not work.
After some search I found "VIDOR_PWM" does not exist in current VidorPeripherals 1.1.0:

I find it in VidorBitstream library instead:

Is that mean current VidorPeripherals 1.1.0 is not up to date?

Hi MattewLing,

there is indeed a bug in VidorPeripheral 1.1.0 about setting the PWM prescaler (solved here Initialize analog period to -1 to allow reconfiguration · vidor-libraries/VidorPeripherals@c54222d · GitHub ).

To make things more complicated, the VIDOR_PWM define indeed disappeared and PWM functionality must be enabled with FPGA.pinMode(33, 3);

Peripheral and Graphics has not been yet updated to GitHub - vidor-libraries/VidorBitstream since there are a couple of regressions to be tackled; the new structure is much more clear and has no side effects.

I'm truly sorry for the missing documentation/not so clear examples but we are working to solve it :slight_smile:

Hi facchinm,

Thank you for your contribution!

I just tried both of your suggestion applied the fix to prescaler and use FPGA.pinMode(33, 3);
Still got no output on the pin.

Looling forward for the updated Peripheral library.