Freezes on download

Hello Arduino Team,

I got an Arduino Duemilanove from the MakerShed the other day as part of the Arduino Starter Kit and whenever I try to download a program the application freezes. I have already checked the board and the faq only to find that this problem could be caused by an already running application. I quickly launched task manager to find that the solution to my problem was not there. Since then I have tried programing my Arduino on 3 different computers running 3 different OSs and still coming up with the same result on all of them. I have read many tutorials and I believe that I am doing everything correctly but it still isn't syncing. Whenever I plug in my Arduino, all the proper lights come on so I don't think it is my board. I triple checked that I was using the right com port so it can't be that. I hope that you can help me.

  • Cornboy3

BUMP

download? upload…?

So you click “upload sketch” and the arduino ide freezes?

Yes that is exactly it. whenever I press the upload button, the IDE just completely freezes and I have to manually end the process.

which version of the IDE? atmega168 or 328 on the Arduino?

and set upload.verbose=true in the preferences.txt and post the last lines of the command line

I have exactly the same problem im running windows xp with a Diecimila board.

I have a similar problem.

I have the Catalyst Pack with Seeeduino Board I am running XP (Same thing seems to happen on my Vista box too) Board is a Seeeduino v1.1 IDE is Arduino v15

The board has three LEDs lit: PWR - Green, on continously TX - Red, flashing (sometimes it stops, not sure if it is anything to do with the issue). Slot 13 (?) - Green, flashing. This isnext to R5 (I think it is the Slot 13 LED, when I put an LED in Slot 13 it flashes at the same rate).

I followed instructions as per the getting started (including setting up the USB Serial driver) IDE is using the Diecimila/Deumilenove w/Atmega168 setting If I click on the serial monitor I get a series of boxes (says it is 9600 baud). If I load the blink example and click "upload to board" the IDE hangs.

Stuck and dissappointed at falling at the first hurdle :(

Can anyone give my any pointers? Thanks

Tom

Running from the bat file:

D:\Dev Tools\arduino-0015>run.bat
Stable Library

Native lib Version = RXTX-2.1-7
Java lib Version = RXTX-2.1-7
Binary sketch size: 976 bytes (of a 14336 byte maximum)
Terminate batch job (Y/N)? y

Anbody got any suggestions?

People are saying that I need to select Diecimila from the Tools -> Boards menu however I am using Wiring 0018 and it doesnt have a Boards option in the tools menu just firmware and Serial port...

Why don't you just download and install Arduino IDE? http://arduino.cc/en/Main/Software

I have the Atmega 328 in an Arduino Duemilanove.

I am running the standard IDE.

I will try running the IDE in verbose mode.