Fresh install 1.6.9, brand new CurieNano, but...

I seem to have received a dud. I downloaded the latest arduino ide. Followed the example on the wiki to load blink (including the Intel curie board core). I get the device recognized by windoze 10. I turns up in the Port menu of IDE. I have selected the correct board.

Get board info returns:

BN: Arduino/Genuino 101 VID: 8087 PID: 0AB6 SN: 00.01

Error on screen is: Arduino: 1.6.9 (Windows 10), Board: "Arduino/Genuino 101"

Sketch uses 17,628 bytes (11%) of program storage space. Maximum is 155,648 bytes. Starting download script... Flashing is taking longer than expected Try pressing MASTER_RESET button ERROR: Timed out waiting for Arduino 101 on COM7 ERROR: Timed out waiting for Arduino 101 on COM7

When I try to load the flashing led pauses for a moment, and then continues on flashing. I changed the blink times to make sure but the led blinks once a second (the default blink on the board).

Any ideas please?

I get the same with 1.6.12 IDE.

Try pressing MASTER_RESET button

Well, did you?

oqibidipo: Well, did you?

Yes, but this only boots the device so it comes back up into same state as a powerup. So as many times as I press the MASTER_RESET it does not clear the problem.

The question is, however, what [u]you[/u] know about the reasons the Flashing is taking too long, on a brand new device out of box, with a fresh install of Arduino IDE, and given the IDE recognises the board. Not to mention that the the code "Blink" is recommended as the hello-world and it fails to upload unmodified from original.

It also fails no matter which programmer type I have selected.

So, what are the faults that can cause the IDE to report that the flashing is taking too long?

I have also tried 1.6.12, re-install of drivers, different cables.

Are you by any chance using USB 3.0 ports ?

Ballscrewbob: Are you by any chance using USB 3.0 ports ?

I have an Aspire M3970 with USB 2.0 ports.

I have just programmed an old Freeduino Host Board in my drawer from the 1.6.12 IDE with Blink so it is weird that I can see and program other boards. See the CurieNano, ask it for ID but then not be able to program it.

So I bought a Genuino 101 and got the same problem. I tried downloading Arduino onto a second PC and got the same problem. DFRobotics won't help as they appear to only solder chips onto boards and so pass the software story here. I contacted Intel with my info and they feel it isnt' the Curie and is likely the IDE.

Glad you are at least able to get it working.

After a while my issue just went away on its own and I have no idea of what actually fixed it.

Occasionally I get it if using the online IDE but even that is quite rare now.

Have you tried to burn a new bootloader ? I know I did this a while ago.

  1. Open the regular IDE.
  2. select the 101 as the board
  3. Select the correct com port for your 101
  4. Select "Programmer Arduino/Genuino 101 Firmware Updater"
  5. select "Burn Bootloader"
  6. Pay attention the the lower console on the IDE. It will prompt you to press reset at some point. Dont do it before it tells you ! and dont wait too long either !

Keep an eye on the lower console.

See if that helps as from memory it may be the only thing I did that could have fixed it.

Ballscrewbob: Glad you are at least able to get it working.

Sorry, nowhere in my thread did I say I got it working.

Intel sent me the Arduino 101 factory recovery flash kit.

It has two instructions, one for JTAG and one for USB.

I have not JTAG gadget and refuse to spend $80 to buy one just to fix this.

The USB upload, of course, does not work on either of my Windows 10 computers nor on any of my USB ports.

This Curie device is a DUD.

I will now create a website called Curie Furie to allow a centralised collection of all the configurations this crap from Intel does not work on.

My bad as I was dealing with a similar thread to yours where things turned out better.

Hi @Asterion, I'm a developer from the Arduino 101 team. Sorry I didn't see this sooner-- we usually hang out on the Issue Tracker for corelibs-arduino101: https://github.com/01org/corelibs-arduino101

Feel free to post there in future, if you find something broken (let's continue to track this one from here, though).

Now, I have a brand new Win10 PC too (2 weeks old), with Arduino 1.6.13 installed, and I've been uploading sketches to Curie devices just fine since that time. So I'm sure we can fix this problem, whether it's on your side or our side :)

Can you give me some extra information?

1) Which version of the Intel Curie Boards package did you install (need the actual release number, not just "the latest" since there has been a release recently)

2) I see you posted about this in several places, and I may not have seen all of them. But I did notice that on purchase page for the tinyTILE board, you mentioned that you got the Arduino 101 factory flashpack, and that it "did not see your board".

https://www.element14.com/community/docs/DOC-82913/l/tinytile-intel-curie-module-based-board

Can you elaborate on this? When you run the flashpack, the first thing it asks you to do is reset the board. Do you mean that after you pressed the reset button, nothing happened? Or did it fail in some other way?