fried USB , FTDI missing on one of my Diecimila

Background:

I ran a program that used :

Serial.begin(115200);

After unplugging from my powerbook ppc osx 10.3.9 the was a warring about unplugging active hardware!

Now the usb does not show up the /dev/tty.usbserialA400... under arduino or with the system profiler

system_profiler SPUSBDataType

gives on an identical board:

FT232R USB UART:

Vendor Name: FTDI Product ID: 24577 ($6001) Speed: Up to 12 Mb/sec Serial Number: A4001JzE Bus Power (mA): 500 system_profiler SPUSBDataType

but nothing with the problem board, both just 2 day old babies!

So have I cooked the FTDI chip or is the a way back to paradise ? or any other ideas please... [smiley=rolleyes.gif]

If you unplug something that has an active serial connection you to reboot your mac. So, reboot an try again.

Yes that was one of the first things I did! (well thanks anyway... :) Then I tried another identical diecimil and it worked! So now I am looking for cheep supply's of ft232rl chips near Belgium, and a small soldering iron (--)^ maybe someone know a fail safe way of testing fr232rl chips!

thanks

If someone knows a test for the FT232RL chip :o, I'm interested too ;D

Windows makes an interesting sound when you plug and unplug USB devices... if it is recognized, it makes a nice sound, if it is not recognized, makes a different sound and you can click on the small USB symbol that appears in the lower right portion of the screen to install drivers, etc. We saw a picture of an Arduino board that lacked one of the electrolytic capacitors, in this same forum, so maybe the FTDI chip has some pins soldered incorrectly... you may try pressing it a little bit and plug the Arduino and see if it is recognized by the OS.

Great idea I have a multimeter so could test the contacts on the chip, will have to get some smaller probes smd stuff sure is small, it doesn’t really look like that is the problem but you never know till you test!
Pushing a little on the ft232rl didn’t so far bring any results!
I think I will try some of the tools on http://www.ftdichip.com/Resources/Utilities.htm and see if I can get anywhere…
Thanks you have given me a little hope :slight_smile:

I've plugged and unplugges Arduino's at least a thousand times and that has never happened... I would say either the board is defective or the chip is not burned. Put an ohmmeter across the PTC fuse- the flat thing with gold pins.

D

The is power going to the diecimila and even a simple blinking led program running fine! (it works on batteries or usb no problem), I did check the PTC fuse and it seems to be fine only about 0.5 ohm across which is the same on the working one. but it still does not appear if I plug it in to the USB port, and as soon as I plug in the other working diecimila it shows up. Anyway I don't see how it could be a power fault if there is power going the ATmega168. e.g. the program is running...

The soldering on the usb connection do look a little over done or something, but the does not seem to be any effect on the connections themselves, see below:

I do still hope it is not a hardware problem, but am getting a little pessimistic :'(

Here are some pics of the underside.

This is the one with the problem:

And this is the one without a problem:

Looks like its corroded or something. :o

It looks like too much flux, but why would the be too much flux on a factory board?

hey

I think yo ujust found the problem: the top image was hand soldered, and th bottom one was wave soldered by machine.

I would send back your board- the hand-soldered connections are probably shorting the USB.

D

Hello abba

Where did you buy the board? No need to spend that much time debugging the distributor or pcb-europe will replace it for free... email them and they'll sort it out for you

massimo

Just got a good email from pcb-europe, Great thanks everyone for your help. :) ;) :D ;D 8-) ::)