Frustrated to the max

I have installed the Arduino IDE on 3 different computers and on all the drivers are not being updated. My Arduino UNO is not being able to communicate with my computer which leaves me in a tough position where I can’t program my Arduino which happens to be part of my science fair experiment.

These are the three computers:
1st computer: iMac
Operating System: High Sierra
2nd computer: Macbook Air
Operating System: Sierra
3rd computer: Dell laptop
Operating System: Windows 10

This is the error message:
Arduino: 1.8.5 (Mac OS X), Board: “Arduino/Genuino Uno”
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 1 of 10: not in sync: resp=0x00
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 2 of 10: not in sync: resp=0x00
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 3 of 10: not in sync: resp=0x00
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 4 of 10: not in sync: resp=0x00
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 5 of 10: not in sync: resp=0x00
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 6 of 10: not in sync: resp=0x00
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 7 of 10: not in sync: resp=0x00
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 8 of 10: not in sync: resp=0x00
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 9 of 10: not in sync: resp=0x00
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 10 of 10: not in sync: resp=0x00
Problem uploading to board.

This is the program:
#define trigPin 12
#define echoPin 11
#define motor 7
#define buzzer 6

void setup()
{ pinMode(trigPin, OUTPUT);
pinMode(echoPin, INPUT);
pinMode(motor, OUTPUT);
pinMode(buzzer,OUTPUT);
}

void loop()
{ long duration, distance;
digitalWrite(trigPin, LOW);
delayMicroseconds(2);
digitalWrite(trigPin, HIGH);
delayMicroseconds(10);
digitalWrite(trigPin, LOW);

duration = pulseIn(echoPin, HIGH);
distance = (duration/2) / 29.1;

if (distance < 100)
{
digitalWrite(motor,HIGH); // When the distance below 100cm
digitalWrite(buzzer,HIGH);
} else
{
digitalWrite(motor,LOW);// when greater than 100cm
digitalWrite(buzzer,LOW);
} delay(500);
}

I have followed all of the instructions for installing the Arduino IDE.
The USB cable is perfectly fine and brand new.
I have tried all programmers that were available in the tools menu.
When you go to the serial port option in tools menu, nothing appears.
I would appreciate a response very soon.

There is a problem with connection to your board / no connection - not in sync: resp=0x00 and no serial port. Very clear signs. First of all, the board have to appear in the device manager. You have to solve this and to load the driver for Arduino on Windows. Is it genuine or clone board?