Frustration with only occasional uploading

I'm getting a bit grumpy because my computer and arduino will talk to each other, but only sometimes.

I seem to have to go through a rigmarole of closing the IDE, plugging the arduino out and in, turning on the ide again, checking the com port is right etc - and then occasionally it'll upload my program. Then if I rejig the program and want to upload it again, the IDE tells me it can't do it because 'the serial port com 1 is already in use'. YES but by the arduino, surely??? So I've made one tiny adjustment and I have to go through five minutes of fiddling about? This cannot be right. Why doesn't it see the arduino when it's already just done so?

I've tried reinstalling the driver. I've changed the com port number, I've been using no2 now I'm using 1. I'm using windows xp. But it never used to give me this aggravation when I was using it before christmas, I'm quite sure? So what's changed?

I'm going mad here. Please can anyone help me or at least reassure me the same thing happens to them? I've read the advice about bluetooth and so on and I don't even know what that means, let alone having installed it or something, so I doubt it's that.


And now I've gone to the FTDI webpage and downloaded the latest interim bug fix files and installed them. Restarted the computer. Tried again. Checked the com port matches. And now all I'm getting is 'problem uploading to board'. That's worse than it was before! I am going to throw myself out of a window next. Why is this so hard?

What OS are you running? Your comments match my experiences with an Uno board and a PC running Ubuntu 9.04 and Arduino IDE 0022. If it works, it only works for a short while before giving errors such as "Port in use" or "Port not found". Digging through the forums seems to indicate that libraries from Ubuntu 11.04 are needed, though I haven't tried this yet.

Meanwhile I've had no problems at all with Windows 7 or XP.

Which Arduino board are you using? Can you post the output of a verbose upload (hold down shift while clicking the upload button)?