Frying motors anxiety

Hey forum!!!!

I just recently got my motors on Wilson(My Bot) working and whenever I start them turning they start to smell funny. I was wondering if there was any way I could tell if I was going to fry them or not.... Thanks

Tim4tech

Measure the current they are drawing and compare that with their current rating at the revs they are turning at. Generally, smell = overload = frying

What are the motors, the power supply and what mechanical load are the motors trying to drive? Burning smells are always bad news.

I am trying to power two 3-6 Volt motors, currently with no load(aka just spinning in the air). This is the first time I have used them and when I turned them on they started making a funny smell. I am using a 9 volt power supply for both the motor controller and the Arduino itself. My motor controller is the standard one with all the tinkerkit options. Not sure how else to describe it.

Tim4tech

tim4tech: I am trying to power two 3-6 Volt motors, currently with no load(aka just spinning in the air). This is the first time I have used them and when I turned them on they started making a funny smell. I am using a 9 volt power supply for both the motor controller and the Arduino itself.

So what's the voltage across a motor when it's on?

If that "9V supply" goes to that motor controller and gets routed to its output/s that's too much for those motors

tim4tech:
I am trying to power two 3-6 Volt motors, currently with no load(aka just spinning in the air). This is the first time I have used them and when I turned them on they started making a funny smell. I am using a 9 volt power supply for both the motor controller and the Arduino itself. My motor controller is the standard one with all the tinkerkit options. Not sure how else to describe it.

Tim4tech

That board is based on the 298. Even with the 298’s 1.8 volt drop, you’ll be putting a bit over 7 volts into that 6 volt motor. But as RP asks, what is the voltage at the motor: you ought to measure that with your meter.

From my early days of playing with electronics (some 50+ years ago) I recall that some model motors used to give a strange smell when running, even at normal speeds with no load. Possibly some sort of reaction between the brush and commutator material under the influence of an electrical spark. If the smell is simply "strange" and not obviously companied by smoke then it could be that all is well

a motor should not smell anyway. a motor has several limits most important one is the current, it should be limited. this limits the heating of the motor. example if the motor is stalled the current is a lot higher as the maximum, so the motor will burn. even if the motor is free the current can still be too high. so check the current. If too high use PWM to bring it down to your maximum. (start small and check the temperature of the motor. The wattage you are having is squared to the voltage so 6 is 1 watt for example and 9 is 2 watts. but please bring it back with PWM. 9 volts is no problem as Voltage the current is a problem.

So I checked the voltage and it is 7.5 without powering the motor controller and 8.5 with powering the motor controller. Is there any way I could lower the voltage and still use a 9 volt?

tim4tech:
Is there any way I could lower the voltage and still use a 9 volt?

You could pad it with diodes, as a sort of “last ditch”.

Dwg attached.

padwdiodes.JPG

Ok, thanks.

On the "smell test"... I've noticed over the years that new things (like motors) often give off an ominous smell that goes away after a while. Always wondered why..... I mentally peg that as "the new smell" and if it does go away, then all is good.

JimboZA: On the "smell test"... I've noticed over the years that new things (like motors) often give off an ominous smell that goes away after a while. Always wondered why..... I mentally peg that as "the new smell" and if it does go away, then all is good.

If oil gets on the commutator it will be vaporised/burnt by the arcing. If the body of the motor isn't getting warm its not a big problem I suggest.

If its a PP3-sized 9V battery you probably won't be able to overheat the motor, battery too puny.

Thanks guys!!!! Believe I got it all working on the correct voltage!!!!! :)

Better now?
No more off smells?
Harmony reigns supreme throughout The Universe once more? 8)

Indeed it does. :D