ft800 (vm800p43-50) error compiling for board arduino uno/genuine

hi
can anyone pls give me a clue bout how to fix this error?

tft libraries are ok
and im using an a4988 stepper driver,so i preferred to program it without a library
also most parts of the code has been generated by EVE screen editor software(latest version)

the whole program is about making a tft lcd work with a stepper motor…
and i already solved other issues

i used my friend’s laptop,installed arduino IDE on it and added libraries and it keeps giving me the same error too…

TFT.ino (4.06 KB)

It’s impossible for us to provide any help for an “error compiling for board arduino uno/genuine” error because there are an infinite number of possible causes of that error. You need to actually look at the contents of the black console window at the bottom of the Arduino IDE to see the specific error. That will point you to what the problem is.

Please do this:

  • When you encounter an error, you’ll see a button on the right side of the orange bar “Copy error messages” in the Arduino IDE (or the icon that looks like two pieces of paper at the top right corner of the black console window in the Arduino Web Editor). Click that button…
  • In a forum reply here, click on the reply field.
  • Click the </> button on the forum toolbar. This will add the forum’s code tags markup to your reply.
  • Press “Ctrl + V”. This will paste the error between the code tags.
  • Move the cursor outside of the code tags before you add any additional text to your reply.

If the text exceeds the forum’s 9000 character limit, save it to a .txt file and post it as an attachment. If you click the “Reply” button here, you will see an “Attachments and other settings” link.

here you are my friend :slight_smile:

error.txt (19.2 KB)

C:\Users\rough\Documents\Arduino\libraries\FTDI_V1.2.0_FT800_/libraries/FT_GC/FT_Transport_SPI/FT_Transport_SPI.h:215:37: error: 'prog_uchar' has not been declared

  void Writefromflash(uint32_t Addr, prog_uchar *Src, uint32_t NBytes)

                                     ^

This indicates that library is very outdated. There was a change in the compiler Arduino uses quite a few years ago that made it so you can no longer use the prog_uchar and similar types. Here is an explanation of the changes that would need to be made to use the library with a modern compiler:

You might look around to see if you can find a newer version of the library that has already been fixed.

well,i don't know almost anything bout AVR programming
can you pls point out which parts should be changed and how to change them?

are these all i need to change?!

replace... ...with...
prog_char char
prog_uchar unsigned char
prog_int8_t int8_t
prog_uint8_t uint8_t
prog_int16_t int16_t
prog_uint16_t uint16_t
prog_int32_t int32_t
prog_uint32_t uint32_t
prog_int64_t int64_t
prog_uint64_t uint64_t

It may be that there are other problems in the code. Start by fixing that obvious one and then see what happens.

Review the two examples. The first corresponds to the FTDI libraries like the one you want to use. The second corresponds to the equivalent created with the modified library for gameduino 23X.

library GD23X modified

library FTDI

PD: the FTDI library is fixed, so it can work with the latest arduino IDEs

Example_1.zip (2.09 KB)

Example_2.zip (852 Bytes)