FTDI chip heating up and computer not recognizing Arduino

I had a mega with a ramps shield. It was all working and one day when I tried powering it on, the computer didn't recognize the arduino. I unplugged the shield and noticed that the FTDI chip was getting untouchably hot within a couple of seconds of being plugged into the computer and the arduino no longer shows up in device manager. The bored is getting power and is not shorting because the on-board power LED is lighting up at normal brightness.

Is there any way to fix this or am I doing something wrong?

Have you tried using the Mega on its own without the shield ?

Maybe just throw the blink sketch at it if it shows up and monitor it for a period provided you have a copy of the original sketch you used for the ramps board of course.

Maybe also include details of your power supply etc too and any other relevant information.

Which board do you say you're using?

The official mega's don't use an FTDI chip, they use a 16u2. Is it really a clone board with an FTDI chip, or did you mean the 16u2?

In any event, that is probably academic. The serial adapter IC is not supposed to get hot, and normally if a chip like that isn't supposed to get hot heats up rapidly, the chip is dead (or is dead now).

I meant the 16u2 on an arduino mega 2560. I tried it without the ramps board, and thats how I realized that the 16u2 was heating up. I can't upload any code to it because my computer can't even recognize it.

Here's my question now: Can I use another arduino (uno) as an ISP through the ISP header on the mega and connect to it that way? I need to be able to upload code to it (which I know the ISP header can do) and connect to the mega through the com port for repetier-host.

The same 16u2 that is used for programming is also what provides the serial connection. Depending on how it's failed, you may or may not be able to use it with an external serial adapter. I think the official board has resistors between the TX/RX of the chip and that of the 16u2 (the pins on the fried 16u2 are likely shorted to ground) so it may work.

The 16u2 seems to be very prone to failure. I also seem to recall several people in the past year who reported that it blew while using it normally with a RAMPS shield (whatever that is).

I would consider buying a new mega - maybe a cheap clone with the ch340G (for all the "omg it's a cheap crappy clone", I don't remember any posts in here where someone's CH340G-based arduino clone had a problem that turned out to be the CH340G itself; multiple people per week post about burned out 16u2).

Yeah I just ordered a new board. The ramps shield allows for stepper drivers and high current outputs to be controlled by the arduino for reprap 3D printers. Because of how many pins you need to run the printer, a mega has to be used.

Hm, I just pulled the schematic on the RAMPS shield.

Am I reading this correctly? Is it using the 5v from the Arduino Mega for the +5V for servos? You’re not supposed to do that - servos put a lot of noise onto the power rail that they’re connected to. I wonder if this could be how the RAMPS shields seem to burn out the 16u2’s - those do often seem to fail when the power rail is abused…

I wasn't using servos either way, but I do agree that that's poor design. It would be more ideal for there to be a regulator to step the 12V down to 5 or a separate 5v input all together.